summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2022-04-07 18:01:55 -0400
committerKevin MacMartin2022-04-07 18:01:55 -0400
commit6799a1d3a47af5e09634225fb6334a58189ceec2 (patch)
treec9114ce099d0a53a041f5a486cd9501e0d9310c5 /PKGBUILD
parent4ace23f47dfedf3fc3b84f4e7df31da59c745d25 (diff)
downloadaur-6799a1d3a47af5e09634225fb6334a58189ceec2.tar.gz
Update to 21.2.r178.g03c61dc8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5309111dd72..686fe6ee9cb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: openfbt
# Contributor: Werecat
# Contributor: Xyne
_pkgname=cjdns
pkgname=$_pkgname-git
-pkgver=21.1.r38.g20ddc268
+pkgver=21.2.r178.g03c61dc8
pkgrel=1
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
@@ -13,7 +14,7 @@ license=('GPL3')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
options=('!distcc' '!strip' '!buildflags')
depends=('bash')
-makedepends=('git' 'nodejs' 'python2' 'binutils' 'llvm')
+makedepends=('cargo' 'git' 'nodejs' 'python2' 'binutils' 'llvm')
optdepends=(
'cjdnsify: allows you to run some programs bound to your cjdns address'
@@ -32,7 +33,7 @@ pkgver() {
build() {
cd $_pkgname
- bash 'do'
+ CJDNS_RELEASE_VERSION="${pkgver}" ./do
}
package() {