summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:47 -0400
committerKevin MacMartin2015-06-10 00:37:47 -0400
commit4f67a628736af58ffea0bb7e96a427c52631e12b (patch)
tree99fb741e46b69ba507adc4fb785d588be44d02d6 /PKGBUILD
downloadaur-4f67a628736af58ffea0bb7e96a427c52631e12b.tar.gz
Initial import into AUR 4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..345908ed27a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+pkgname=cjdnsify
+pkgver=20140717.r6.bc354af
+pkgrel=1
+pkgdesc="Limit network access of bind-compatible programs to the local cjdns network"
+url="https://github.com/prurigro/${pkgname}"
+license=('GPL')
+depends=('bash' 'cjdns-git' 'force_bind')
+makedepends=('git')
+arch=('any')
+backup=("etc/default/${pkgname}")
+
+source=("git://github.com/prurigro/${pkgname}.git#branch=master")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 $pkgname "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 ${pkgname}.conf "${pkgdir}/etc/default/${pkgname}"
+}