summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralzeih2020-08-20 22:51:40 +1200
committeralzeih2020-08-20 22:51:40 +1200
commit3d98c31024e86eb9b97cc3401d06f969e9c60f85 (patch)
treee19e338d1c950dc919fd49ba7924b8a4c17b0853 /PKGBUILD
downloadaur-3d98c31024e86eb9b97cc3401d06f969e9c60f85.tar.gz
Version 0.6.1-1
Signed-off-by: alzeih <alzeih@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fa086902523
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: alzeih <alzeih@users.noreply.github.com>
+pkgname=cjose
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="C library implementing the Javascript Object Signing and Encryption (JOSE)"
+arch=('x86_64')
+url="https://github.com/cisco/cjose"
+license=('MIT')
+depends=('openssl' 'jansson')
+makedepends=('jansson')
+source=("https://github.com/cisco/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('7ae67a6d19591b3d19b888270ec0ca17df399bea117e42686fc1de39b3741ed9a8816f96d33d090687c49c3123cdc95430a781835a525a02d22561ebf5aaa653')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}