summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChucklesTheBeard2015-06-09 21:14:38 -0400
committerChucklesTheBeard2015-06-09 21:14:38 -0400
commitc27184bce9bcbbbafe4b5b0535f295d11fe81de0 (patch)
tree3d80b942a97f15ae237f4fa889a908146eca17dd /PKGBUILD
downloadaur-c27184bce9bcbbbafe4b5b0535f295d11fe81de0.tar.gz
Commit to AUR 4.0.0
- CKAN update to 1.6.22r2 - no packaging changes otherwise
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b983fa9e5981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Andrew Smith <ChucklesTheBeard@gmail.com>
+# Contributer: Patrik Plihal <patrik.plihal@gmail.com>
+
+pkgname=ckan-git
+pkgver=v1.6.22.r2.g72052f3
+pkgrel=1
+pkgdesc="A metadata repository and associated tools for searching, installing, and managing mods for Kerbal Space Program (KSP)"
+arch=('any')
+url="http://forum.kerbalspaceprogram.com/threads/100067-"
+license=('MIT')
+provides=('ckan')
+depends=('mono' 'curl')
+makedepends=('git' 'python2' 'python2-requests')
+source=('git://github.com/KSP-CKAN/CKAN'
+ 'disable_version_checks.diff')
+md5sums=('SKIP'
+ '0e79190f162aa2daf362b3c259e2e1fa')
+
+pkgver() {
+ cd "$srcdir/CKAN"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+
+ # ignore certain version checks that return "inconclusive" exceptions for development builds
+ cd "$srcdir/CKAN/"
+ git apply $srcdir/disable_version_checks.diff
+}
+
+build() {
+ cd "$srcdir/CKAN"
+ xbuild /verbosity:minimal CKAN.sln
+
+ cd "$srcdir/CKAN/Cmdline"
+ mono ../Core/packages/ILRepack.1.25.0/tools/ILRepack.exe \
+ /target:exe \
+ /out:$srcdir/ckan.exe \
+ bin/Debug/CmdLine.exe \
+ bin/Debug/CKAN-GUI.exe \
+ bin/Debug/ChinhDo.Transactions.dll \
+ bin/Debug/CKAN.dll \
+ bin/Debug/CommandLine.dll \
+ bin/Debug/ICSharpCode.SharpZipLib.dll \
+ bin/Debug/log4net.dll \
+ bin/Debug/Newtonsoft.Json.dll \
+ bin/Debug/INIFileParser.dll \
+ bin/Debug/CurlSharp.dll
+}
+
+check() {
+ #nunit-console4 is included in mono
+
+ cd "$srcdir/CKAN/"
+ command nunit-console4 --exclude=FlakyNetwork Tests/bin/Debug/CKAN.Tests.dll
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ cp $srcdir/ckan.exe "$pkgdir/usr/bin/ckan"
+}
+
+# vim:set ts=2 sw=2 et: