summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis2021-09-21 02:41:39 +0300
committerTasos Sahanidis2021-09-21 02:42:01 +0300
commit0bdce625033c590a0eab76ec1781452672c61b38 (patch)
treee35cf5ed19f68874cea50f875e3d036246c69213 /PKGBUILD
parent32dab8610af3ac93a3696e222a291eb5c2032256 (diff)
downloadaur-0bdce625033c590a0eab76ec1781452672c61b38.tar.gz
Backport uinput scroll wheel fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30c46ca2ba7e..4e1b2823b9fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
pkgver=0.4.4
-pkgrel=1
+pkgrel=2
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64')
url="https://github.com/ckb-next/ckb-next"
@@ -13,8 +13,10 @@ optdepends=('libpulse')
conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next-git')
provides=('ckb-next')
install=ckb-next.install
-source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('6946bd035cdbbbd2f139e543d2ca84ba422176c62c3a3665b544118dc6d618d0')
+source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz"
+ 'dc4dc54c5ebac7e4b455d8df35076fc044a581a7.patch')
+sha256sums=('6946bd035cdbbbd2f139e543d2ca84ba422176c62c3a3665b544118dc6d618d0'
+ 'ca662407404a0b22c3f2706f729717ab73575101247689ce80b7528fea0de87e')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -30,10 +32,10 @@ build() {
cmake --build build --target all
}
-#prepare() {
-# cd "$srcdir/${pkgname}-${pkgver}"
-# patch -p1 -i "$srcdir/a9f41cd8b8f5b04c0c66c6d94f96a9725943831e.patch"
-#}
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -p1 -i "$srcdir/dc4dc54c5ebac7e4b455d8df35076fc044a581a7.patch"
+}
package() {
cd "$srcdir/${pkgname}-${pkgver}"