summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOleksii Vilchanskyi2018-05-01 11:02:08 +0200
committerOleksii Vilchanskyi2018-05-01 11:02:08 +0200
commit183cf8e348632456e6f81762d711c7eb425cfcc3 (patch)
treecb4a631b5fd42ec234333812bca2896dab17241c /PKGBUILD
parent67f6f8b72d8103f217ba788bc491c53812ae6b46 (diff)
downloadaur-183cf8e348632456e6f81762d711c7eb425cfcc3.tar.gz
Update to 0.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b67b47ffbdeb..5a8d706e2bd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,33 @@
# Maintainer: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
-pkgver=0.2.9
+pkgver=0.3.0
pkgrel=1
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64')
url="https://github.com/mattanger/ckb-next"
license=('GPL2')
depends=('qt5-base' 'hicolor-icon-theme')
-makedepends=('git')
-optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)'
- 'libappindicator-gtk3: Ayatana indicators in Unity, KDE or Systray (GTK+ 3 library)')
+makedepends=('git' 'cmake')
+optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)')
conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next')
provides=('ckb-next')
install=ckb-next.install
source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('6e1da1f4ee5f1e9132f92ec7ad268499')
+md5sums=('df3d0820f8f6a842bfe2a371adf4a60e')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./qmake-auto
- make -j$(nproc --all)
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ cmake -H. -Bbuild \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_LIBEXECDIR="lib"
+ cmake --build build --target all
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- install -dm755 "$pkgdir/usr/bin"
- install -dm755 "$pkgdir/usr/lib/ckb-animations"
- install -Dm755 bin/ckb{,-daemon} "$pkgdir/usr/bin/"
- install -D bin/ckb-animations/* "$pkgdir/usr/lib/ckb-animations/"
-
- install -Dm644 usr/ckb.png "$pkgdir/usr/share/icons/hicolor/512x512/apps/ckb.png"
- install -Dm644 usr/ckb.desktop "$pkgdir/usr/share/applications/ckb.desktop"
+ cd "$srcdir/${pkgname}-${pkgver}"
- install -Dm644 service/systemd/ckb-daemon.service "$pkgdir/usr/lib/systemd/system/ckb-daemon.service"
- install -Dm644 udev/99-ckb-daemon.rules "$pkgdir/etc/udev/rules.d/99-ckb-daemon.rules"
+ DESTDIR="$pkgdir" cmake --build build --target install
}