summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTasos Sahanidis2022-06-20 23:06:26 +0300
committerTasos Sahanidis2022-06-20 23:06:26 +0300
commit31ac2f799bb5e52e60784096b4e17c1eb10c80a4 (patch)
tree327545aba6376548412bc98a44d8a2e74afeac41 /PKGBUILD
parentf7c1a4a2912f3fb9837af57e9fd282c50795e2c9 (diff)
downloadaur-31ac2f799bb5e52e60784096b4e17c1eb10c80a4.tar.gz
Fix autostart option not showing up
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c76d89818da..4206452d6afc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'pentium4')
url="https://github.com/ckb-next/ckb-next"
license=('GPL2')
depends=('qt5-base' 'hicolor-icon-theme' 'quazip-qt5' 'qt5-tools' 'libxcb' 'xcb-util-wm' 'qt5-x11extras' 'libdbusmenu-qt5' 'python3' 'python-pyqt5')
@@ -14,9 +14,11 @@ conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next-git')
provides=('ckb-next')
install=ckb-next.install
source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz"
- 'AUR-wrapper::git+https://github.com/ckb-next/AUR-wrapper.git')
+ 'AUR-wrapper::git+https://github.com/ckb-next/AUR-wrapper.git'
+ '0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch')
sha256sums=('12705aa86cb544a77df6d7a73744f21513bcc6cce805ed8caf5d3b72a950157e'
- 'SKIP')
+ 'SKIP'
+ '6cddbf71179ad385d89b9a2ed318b0fa3dd5817b5bcfd4432d22b088d183bfcd')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -34,6 +36,7 @@ build() {
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
+ patch -p1 -i "$srcdir/0001-Fix-autostart-checkbox-detection-with-renamed-binary.patch"
}
package() {