summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOleksii Vilchanskyi2017-06-28 02:50:47 +0200
committerOleksii Vilchanskyi2017-06-28 02:50:47 +0200
commit7cf725530788fa505a70b767a1f32c7e3112f42f (patch)
tree8b9955aeb97f704cd1eb42b9e6f829d9cf13c52b /PKGBUILD
downloadaur-7cf725530788fa505a70b767a1f32c7e3112f42f.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..317814303f3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Light2Yellow <alexvilchansky@yahoo.com>
+
+pkgname=ckb-next
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
+arch=('i686' 'x86_64')
+url="https://github.com/mattanger/ckb-next"
+license=('GPL2')
+depends=('qt5-base' 'hicolor-icon-theme')
+makedepends=('git')
+conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next-git' 'ckb-next-latest-git')
+install=ckb-next.install
+source=("https://github.com/mattanger/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('bb2f354559fedc6883acc0a478e7e59a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./qmake-auto
+ make -j$(nproc --all)
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/lib/ckb-animations"
+ install -Dm755 bin/ckb{,-daemon} "$pkgdir/usr/bin/"
+ install -D bin/ckb-animations/* "$pkgdir/usr/lib/ckb-animations/"
+
+ install -Dm644 usr/ckb.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/ckb.png"
+ install -Dm644 usr/ckb.desktop "${pkgdir}/usr/share/applications/ckb.desktop"
+
+ install -Dm644 service/systemd/ckb-daemon.service "${pkgdir}/usr/lib/systemd/system/ckb-daemon.service"
+}