summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Schulte2019-10-22 13:34:00 -0400
committerEric Schulte2019-10-22 13:43:58 -0400
commitbc494de17e27d5c953ee75999b54375776e643f2 (patch)
tree484c1e82b21e7a81d536bc44f2a02f79680c426f /PKGBUILD
downloadaur-bc494de17e27d5c953ee75999b54375776e643f2.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da12d185e0a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Eric Schulte <eschulte@grammatech.com>
+# Maintainer: Eric Schulte <eschulte@grammatech.com>
+_srcname=protobuf
+pkgname=cl-${_srcname}-git
+pkgver=r128.bfcde84
+pkgrel=1
+pkgdesc="Protobuf is a Common Lisp implementation of Google's protocol buffers."
+arch=('x86_64')
+url="https://github.com/brown/protobuf"
+license=('BSD')
+optdepends=('boost' 'protobuf')
+depends=()
+makedepends=('git' 'make')
+provides=("cl-${_srcname}")
+# source=('git://github.com/brown/protobuf.git')
+source=('git+file:///home/eschulte/lisp/local-projects/protobuf')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_srcname/protoc/lisp/"
+ cp /usr/include/google/protobuf/stubs/strutil.h .
+ INSTALL_ROOT=/usr/ PROTOC_ROOT=/usr/ make
+}
+
+package() {
+ cd "$_srcname/protoc/lisp/"
+ mkdir -p "$pkgdir"/usr
+ INSTALL_ROOT="$pkgdir"/usr/ PROTOC_ROOT=/usr/ make install
+}