summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDacoda Strack2017-02-27 23:14:06 -0800
committerDacoda Strack2017-02-27 23:14:06 -0800
commit054ef13912c5388d97fc782df905f851a2b054cc (patch)
treeefb233b7720d6ded182a86859ea62316b0e7773d /PKGBUILD
downloadaur-054ef13912c5388d97fc782df905f851a2b054cc.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9564a8aec128
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dacoda Strack <dacoda.strack@gmail.com>
+
+pkgname=cl-zpb-ttf
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Use truetype fonts in common lisp"
+arch=('any')
+url=""
+license=('custom:unknown')
+source=("git+https://github.com/xach/zpb-ttf.git#commit=6c791440ea9eae584f3f98caeda0ea011fdde132")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname#cl-}
+ echo $(cat zpb-ttf.asd | grep version | sed -e 's/ :version \"\(.*\)\"/\1/')
+}
+
+package() {
+ cd ${pkgname#cl-}
+
+ # Install documentation
+ install -d ${pkgdir}/usr/share/doc/$pkgname/
+ install -m644 doc/index.html ${pkgdir}/usr/share/doc/$pkgname/
+ install -m644 doc/lambda.png ${pkgdir}/usr/share/doc/$pkgname/
+
+ # Install source and *.asd files
+ install -d ${pkgdir}/usr/share/common-lisp/source/${pkgname}
+
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.lisp
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${pkgname} *.asd
+
+ # Link *.asd files appropriately
+ install -d ${pkgdir}/usr/share/common-lisp/systems
+
+ cd ${pkgdir}/usr/share/common-lisp/systems
+ ln -s ../source/${pkgname}/*.asd
+}