summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaansu2015-08-02 00:10:43 -0700
committerRaansu2015-08-02 00:10:43 -0700
commit304f41a014a60c767c01f46c9cecc8f195ffc32b (patch)
treef42b70ceb4d61d851db16edd7e9db991c53009e3 /PKGBUILD
downloadaur-304f41a014a60c767c01f46c9cecc8f195ffc32b.tar.gz
Clean up depends and make depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3322cce033d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Raansu <gero3977 at gmail dot com>
+# Based on PKGBUILD from vertcoin-git maintained by Lothar_m <lothar_m at riseup dot net>
+# Clams original code by nochowderforyou <https://github.com/nochowderforyou>
+
+pkgname='clam-git'
+_gitname=clams
+pkgver=1.4.16
+pkgrel=1
+arch=('any')
+url="http://www.clamclient.com"
+depends=('qt4' 'gcc-libs' 'miniupnpc' 'openssl' 'db4.8' 'protobuf')
+makedepends=('pkg-config' 'git' 'boost-libs' 'boost' 'gcc' 'qrencode' 'make' 'automoc4' 'automake' 'autoconf' 'libtool')
+license=('MIT')
+pkgdesc="The most widely held crypto-currency ever! This package provides both the GUI QT4 and daemon clients."
+provides=('clam-qt' 'clamd')
+conflicts=('clam-qt' 'clamd')
+source=("git://github.com/nochowderforyou/clams.git")
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/$_gitname
+ ./autogen.sh
+ ./configure
+ make
+}
+
+
+package() {
+ # install clam-qt client
+ install -D -m755 "$srcdir/$_gitname/src/qt/clam-qt" "$pkgdir/usr/bin/clam-qt"
+
+ # install clam daemon
+ install -D -m755 "$srcdir/$_gitname/src/clamd" "$pkgdir/usr/bin/clamd"
+
+ # install license
+ install -D -m644 "$srcdir/$_gitname/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}