summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-06-13 19:09:56 +0200
committerGoliathLabs2020-06-13 19:09:56 +0200
commit57ae52d651e22a21024dc8d3a7427bca7fa8370c (patch)
treea719d37d1be0090e96c6ea7c16edaab70dc84cb6 /PKGBUILD
parent210bd9b82b5e8c98fb07541a18b63a492200c0b4 (diff)
downloadaur-57ae52d651e22a21024dc8d3a7427bca7fa8370c.tar.gz
Updated: 0.102.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD109
1 files changed, 75 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fc7d8b173ce..b7e8d9b3d688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,89 @@
-# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Steven Honeyman <stevenhoneyman at gmail com>
-pkgname=clamav-light
_pkgname=clamav
-pkgver=0.99.2
+pkgname=$_pkgname-light
+pkgver=0.102.3
pkgrel=1
-pkgdesc="ClamAV manual scanner"
-arch=('i686' 'x86_64')
-url="http://www.clamav.net/"
+pkgdesc='Anti-virus toolkit for Unix'
+url='https://www.clamav.net/'
license=('GPL')
-depends=('bzip2' 'gcc-libs' 'libltdl')
-makedepends=('intltool' 'autoconf')
+arch=('i686' 'x86_64')
+depends=('bzip2' 'gcc-libs' 'libltdl' 'systemd-libs')
+makedepends=('libmilter' 'systemd')
+checkdepends=('check')
+backup=('etc/clamav/clamd.conf'
+ 'etc/clamav/freshclam.conf'
+ 'etc/clamav/clamav-milter.conf'
+ 'etc/logrotate.d/clamav')
conflicts=('clamav')
-source=("https://www.clamav.net/downloads/production/${_pkgname}-${pkgver}.tar.gz"
- 'make_it_compile_against_openssl_1_1_0.patch')
-sha256sums=('167bd6a13e05ece326b968fdb539b05c2ffcfef6018a274a10aeda85c2c0027a'
- '0a8e02a91bc3f2c99bd52dc475592637376baa991fe3f899b7745b840fc586c5')
+provides=(libclamav.so libclamunrar.so libclamunrar_iface.so clamav)
+source=(https://www.clamav.net/downloads/production/${_pkgname}-${pkgver}.tar.gz{,.sig}
+ clamav.logrotate
+ clamav.tmpfiles
+ clamav.sysusers)
+sha512sums=('d239718814b303fb0f1655d9bdaf3675d888eea57e786d927eafabb7b6f58cd7f5fb7dc149511c2af6f800dcc919f2e1d6954110d45b9e16619c632e8d2b37f2'
+ 'SKIP'
+ '9cb168c1c16bb43c99900d7ef34456e3f3b593d4d1943c875a0306bc86fd3872cb78e9e1413dcba93579e01b96d466c9eea1975e24190193663b7986c4525d48'
+ 'c5443634399bd87fe0d0192518538ffdb7296a8437b5b0160a0fbd58696b01285de3237e3feb552c0095c49e576832dec2e2b2107eef2be42424ed7edd13cd19'
+ 'b984836f6c34d97b90d81fa5d17361a2e3f8c0cc709e3350a4d25cf088dc04f7bf2504359980c8be489c96b1b8798c60e6da533069d3378d49d4f50f929a2c90')
+validpgpkeys=('65ED513993F08DA06F9639A6F13F9E16BCA5BFAD') # Talos (Talos, Cisco Systems Inc.) <research@sourcefire.com>
prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
- patch -Np1 -i ../make_it_compile_against_openssl_1_1_0.patch
- sed -i '/clamsubmit/s/^/#/ ; /^pkgconfig/s/^/#/ ; /^bin_SCRIPTS/s/^/#/ ; s/^SUBDIRS.*/SUBDIRS = libclamav clamscan freshclam docs/' ./Makefile.am
- sed -i 's/^man_MANS.*/man_MANS = man\/clamscan.1 man\/freshclam.1 man\/freshclam.conf.5/' ./docs/Makefile.am
- autoreconf -fi
+ cd ${_pkgname}-${pkgver}
+ sed -E 's|^(Example)$|#\1|' -i etc/{clamd,freshclam,clamav-milter}.conf.sample
+ sed -E 's|#(User) .+|\1 clamav|' -i etc/{clamd,freshclam,clamav-milter}.conf.sample
+ sed -E 's|#(LogFile) .+|\1 /var/log/clamav/clamd.log|' -i etc/clamd.conf.sample
+ sed -E 's|#(LogTime) .+|\1 yes|' -i etc/clamd.conf.sample etc/clamav-milter.conf.sample
+ sed -E 's|#(PidFile) .+|\1 /run/clamav/clamd.pid|' -i etc/clamd.conf.sample
+ sed -E 's|#(TemporaryDirectory) .+|\1 /tmp|' -i etc/{clamd,clamav-milter}.conf.sample
+ sed -E 's|#(LocalSocket) .+|\1 /run/clamav/clamd.ctl|' -i etc/clamd.conf.sample
+ sed -E 's|#(UpdateLogFile) .+|\1 /var/log/clamav/freshclam.log|' -i etc/freshclam.conf.sample
+ sed -E 's|#(DatabaseMirror) .+|\1 database.clamav.net|' -i etc/freshclam.conf.sample
+ sed -E 's|#(NotifyClamd) .+|\1 /etc/clamav/clamd.conf|' -i etc/freshclam.conf.sample
+ sed -E 's|#(PidFile) .+|\1 /run/clamav/freshclam.pid|' -i etc/freshclam.conf.sample
+ sed -E 's|#(LogFile) .+|\1 /var/log/clamav/clamav-milter.log|' -i etc/clamav-milter.conf.sample
+ sed -E 's|#(PidFile) .+|\1 /run/clamav/clamav-milter.pid|' -i etc/clamav-milter.conf.sample
+ sed -E "s|(\\[Unit\\])|\\1\\nWants=network-online.target\\nAfter=network-online.target|" -i freshclam/clamav-freshclam.service.in
+ autoreconf -fiv
}
-
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- ./configure --prefix=/usr --sysconfdir=/etc --with-dbdir=/var/lib/clamav \
- --disable-clamav --enable-dns-fix --with-gnu-ld --without-included-ltdl \
- --disable-milter --disable-ipv6 --disable-clamdtop --disable-fanotify \
- --disable-unrar --enable-llvm=no --disable-zlib-vcheck
- make
+ cd ${_pkgname}-${pkgver}
+ # --disable-zlib-vcheck because the configure script thinks that
+ # zlib 1.2.11 is older than 1.2.2
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/clamav \
+ --with-dbdir=/var/lib/clamav \
+ --with-user=clamav \
+ --with-group=clamav \
+ --with-system-libmspack \
+ --disable-rpath \
+ --disable-clamav \
+ --disable-llvm \
+ --disable-zlib-vcheck \
+ --enable-milter \
+ --disable-clamdtop
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ cd ${_pkgname}-${pkgver}
+ make check
}
package() {
- cd "$srcdir/clamav-$pkgver"
- mkdir -p -m755 "$pkgdir/etc"
- mkdir -p -m777 "$pkgdir/var/lib/clamav"
- make DESTDIR="$pkgdir" install-strip
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ mv "${pkgdir}"/etc/clamav/freshclam.conf{.sample,}
+ mv "${pkgdir}"/etc/clamav/clamd.conf{.sample,}
+ mv "${pkgdir}"/etc/clamav/clamav-milter.conf{.sample,}
- # config file for freshclam
- echo "IyBmcmVzaGNsYW0gY29uZmlnIGZpbGUgKGNsYW1B
- VikKCkRhdGFiYXNlRGlyZWN0b3J5IC92YXIvbGli
- L2NsYW1hdgpEYXRhYmFzZU1pcnJvciBkYXRhYmFz
- ZS5jbGFtYXYubmV0CkZvcmVncm91bmQgeWVzClRl
- c3REYXRhYmFzZXMgeWVzCg==" | tr -d " " | base64 -d >"$pkgdir/etc/freshclam.conf"
+ install -Dm 644 ../clamav.sysusers "${pkgdir}"/usr/lib/sysusers.d/clamav.conf
+ install -Dm 644 ../clamav.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/clamav.conf
+ install -Dm 644 ../clamav.logrotate "${pkgdir}"/etc/logrotate.d/clamav
}