summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2024-04-12 04:18:05 +0800
committerlilac2024-04-12 04:18:05 +0800
commit1bdb80ff38d2d77c76e849171913afb439a4bd6d (patch)
treede450b76ee7fb9baee31257e74582ad9512e02c1 /PKGBUILD
parente08a333bbb756711ff739d433b379c3110c5f79c (diff)
downloadaur-1bdb80ff38d2d77c76e849171913afb439a4bd6d.tar.gz
[lilac] updated to 202404110057-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 179b456476de..7e8301f4eaa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
# Maintainer: Dct Mei <dctxmei@yandex.com>
pkgname=clash-geoip
-pkgver=20240407
-pkgver() {
- date +'%Y%m%d'
-}
+pkgver=202404110057
pkgrel=1
pkgdesc="GeoIP files for Clash"
arch=(any)
-url="https://github.com/MetaCubeX/meta-rules-dat"
+url="https://github.com/Loyalsoldier/geoip"
license=(CC-BY-SA-4.0 GPL-3.0-or-later)
-source=("$url/raw/release/country.mmdb")
-sha256sums=('4c57de73a8a87129fb0b0c4230e8dfa22a0559e54e096164c4a87974a0ec8675')
+source=("${pkgname}-${pkgver}.mmdb::${url}/releases/download/${pkgver}/Country.mmdb")
+sha256sums=('f0eb6e1ea132ecc67277cf553a695ba839dbe97a219ed57dbd5db4a0519f5825')
package() {
- install -Dm644 country.mmdb "$pkgdir/etc/clash/Country.mmdb"
+ install -Dm0644 "${pkgname}-${pkgver}.mmdb" "${pkgdir}/etc/clash/Country.mmdb"
}