summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormidnightix2021-12-21 11:26:29 +0800
committermidnightix2021-12-21 11:26:29 +0800
commitf124c79073f8a4a823f5d3b51185d4b2a7f7b6c4 (patch)
tree25ac3ee5a3df9953d299beee66eb880b58b76342 /PKGBUILD
parent8ee90f2f1ba0205cca02d00962501e20502cc6b8 (diff)
downloadaur-f124c79073f8a4a823f5d3b51185d4b2a7f7b6c4.tar.gz
fix VCS version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e131f030fef5..37a8f237ea6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: midnightix <midnightix@protonmail.com>
pkgname=clash-premium-script
+_pkgname=clash-premium-installer
pkgver=r11.e729951
-pkgrel=1
+pkgrel=2
pkgdesc="Simple clash premium core script for Linux."
arch=('any')
url="https://github.com/Kr328/clash-premium-installer"
@@ -11,13 +12,18 @@ install=${pkgname}.install
depends=('clash-premium-bin' 'systemd' 'nftables' 'iproute2')
makedepends=('git')
backup=("etc/clash/config.yaml" "etc/default/clash")
-source=("git+https://github.com/Kr328/clash-premium-installer.git#commit=e729951"
+source=("git+https://github.com/Kr328/clash-premium-installer.git"
"arch.patch"
"config.yaml")
sha256sums=('SKIP'
'b12839b50154a1ff31fa6aa2e9de482ddd9a2bcd45a83bed0fae11549d479646'
'1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0')
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd "${srcdir}"/clash-premium-installer/
git apply ../arch.patch