summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn W. Burton2022-06-07 10:29:58 -0400
committerTarn W. Burton2022-06-07 10:29:58 -0400
commit22a9011c2d975f5b8b791935e453906b6f268c71 (patch)
tree469367c3788026815fbb50ed4317b32a2e468bb3 /PKGBUILD
parentb6e822758c2adc695cdb434485247dc55adc7641 (diff)
downloadaur-22a9011c2d975f5b8b791935e453906b6f268c71.tar.gz
Update versioning scheme
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2fd32ce5e43..0dffb264a94c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn W. Burton <twburton@gmail.com>
pkgname=clasp-cl-git
-pkgver=1.0.0.r214.gfdfb2e6d3
+pkgver=1.0.0_262_g0eb80f93e
pkgrel=1
pkgdesc="Bringing Common Lisp and C++ Together"
arch=('x86_64')
@@ -15,14 +15,19 @@ conflicts=('cando-git')
source=('git+https://github.com/clasp-developers/clasp.git')
sha512sums=('SKIP')
+prepare() {
+ cd clasp
+ ./koga --package-path=$pkgdir --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
+ ./koga --skip-sync --update-version
+}
+
pkgver() {
cd clasp
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ sbcl --noinform --non-interactive --eval "(write-string (substitute #\_ #\- (getf (with-open-file (s \"version.sexp\") (read s)) :version)))"
}
build() {
cd clasp
- ./koga --package-path=$pkgdir --bin-path=/usr/bin/ --share-path=/usr/share/clasp/ --lib-path=/usr/lib/clasp/
ninja -C build
}