summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn W. Burton2021-07-06 15:56:45 -0400
committerTarn W. Burton2021-07-06 15:56:45 -0400
commit2e6c7afe4c416454cd4a172b59e638fee5988f8c (patch)
treefbb07336cd15d27f4b6b1b6ac7baa07f42490784 /PKGBUILD
parent3a03af32e1031ccfd65e53746e6263c49e994d74 (diff)
downloadaur-2e6c7afe4c416454cd4a172b59e638fee5988f8c.tar.gz
Update for snapshot
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 28 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69ce0e111fda..b9d938aefca7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,62 @@
# Maintainer: Tarn W. Burton <twburton@gmail.com>
_srcname=clasp
+_qlver=2021-02-13
pkgname=clasp-cl
pkgname=clasp-cl-git
-pkgver=0.4.2.r4358.g19fef908c
+pkgver=0.4.2.r4453.gee36ba131
pkgrel=1
pkgdesc="Bringing Common Lisp and C++ Together"
arch=('x86_64')
url="https://github.com/clasp-developers/clasp"
license=('LGPL')
+options+=(!strip)
depends=('boost' 'expat' 'gmp' 'libbsd' 'libedit'
'libelf' 'libffi' 'llvm13' 'netcdf' 'ncurses' 'zlib')
makedepends=('git' 'python' 'sbcl')
provides=('cclasp-boehm' 'common-lisp' 'clasp-cl' 'cando')
source=('git://github.com/clasp-developers/clasp.git'
- 'wscript.config')
+ 'git://github.com/clasp-developers/seqan-clasp.git'
+ 'git://github.com/cando-developers/cando.git'
+ "https://github.com/quicklisp/quicklisp-client/archive/refs/tags/version-$_qlver.tar.gz"
+ 'wscript.config'
+ 'clasp.sh')
sha512sums=('SKIP'
- 'd58f230bdd46e814d807fccb8cfc84c742b77f08bad219159d2dc70a6b867d90ff0d33fcb9d4bfbbfed58a4aaef77d815e9274f12d55b1ff041910dc788b28a0')
+ 'SKIP'
+ 'SKIP'
+ '8efec9d46f0008c9f2fab387837f5a02d60ebb9f4a83106142ae954bc322b99bd48f9e91e2107dda188d679e27ddb5f48e444adfa98e6c15cf454923dfccadd5'
+ '1924197ff79d93f4683f3a818f1b5f7f9f26c107dbe6b6ea74a810608e38570bba50852fc0636753bedfee1e0dff2abbfe2394c721014de7d66350ca14aacdec'
+ '1624ca5ba9502afbcfe8c603590c884c3081162a94f86eded74ec8f1e2a1a2ca03694e2bef4190473b6c34230a478b2e95a87b5c458ff60028ca9b740cc173cd')
pkgver() {
cd "$_srcname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_srcname"
+ git submodule add -f $srcdir/seqan-clasp extensions/seqan-clasp
+ git submodule add -f $srcdir/cando extensions/cando
+}
+
build() {
cd "$_srcname/"
cp ../wscript.config .
- if [ ! -e "extensions/cando" ]; then
- git clone https://github.com/cando-developers/cando extensions/cando
- else
- cd extensions/cando && git fetch && git pull && cd ../..
- fi
- if [ ! -e "extensions/seqan-clasp" ]; then
- git clone https://github.com/clasp-developers/seqan-clasp.git extensions/seqan-clasp
- else
- cd extensions/seqan-clasp && git fetch && git pull && cd ../..
- fi
sed -i s/\"--link-static\",//g wscript
sed -i s/stlib/lib/g extensions/cando/wscript
sed -i s/STLIB/LIB/g extensions/cando/wscript
./waf configure --enable-jupyter
- ./waf build_dboehmprecise
+ CLASP_QUICKLISP_DIRECTORY=$srcdir/quicklisp-client-version-$_qlver ./waf build_dboehmprecise
}
package() {
cd "$_srcname/"
./waf install_dboehmprecise --destdir "$pkgdir"
+ install -o root -m 755 ../clasp.sh "$pkgdir/usr/bin/clasp"
+ CLASP_QUICKLISP_DIRECTORY=$srcdir/quicklisp-client-version-$_qlver CLASP_FEATURES=ignore-extensions ./build/boehmprecise/iclasp-boehmprecise -N -l 'quicklisp:setup.lisp' -e '(ql:quickload :common-lisp-jupyter)' -e "(clj:install :use-implementation t :system t :bin-path \"/usr/bin/clasp\" :prefix \"$pkgdir\")"
+ CLASP_QUICKLISP_DIRECTORY=$srcdir/quicklisp-client-version-$_qlver ./build/boehmprecise/icando-boehmprecise -N -e '(ql:quickload :cando-jupyter)' -e "(cando-jupyter:install :system t :bin-path \"/usr/bin/icando\" :prefix \"$pkgdir\")" \
+ -e "(cando-jupyter:install :system t :image t :bin-path \"/usr/bin/cando\" :prefix \"$pkgdir\")"
+ sed -i '/"\/usr\/bin\/clasp",.*/a "--load", "quicklisp:setup.lisp",' $pkgdir/usr/share/jupyter/kernels/common-lisp_clasp/kernel.json
+ mkdir -p "$pkgdir/usr/lib/clasp/src/lisp/modules/quicklisp"
+ cp -ra $srcdir/quicklisp-client-version-$_qlver/* "$pkgdir/usr/lib/clasp/src/lisp/modules/quicklisp/"
}
+