summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-10-02 14:32:10 +0200
committerChristian Hesse2015-10-02 14:32:10 +0200
commit5212d3a5f5f53acee5f086180e286378f549ad85 (patch)
treef36443fa6509ae6159531c612594b5700447d519 /PKGBUILD
parent42574fad71d8548e1840bc77ef533a2072827ff0 (diff)
downloadaur-5212d3a5f5f53acee5f086180e286378f549ad85.tar.gz
commit claws-mail-git 3.12.0.r96.g3c64fb6-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab12594dc397..957fac392b70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=claws-mail-git
-pkgver=3.12.0.r1.g3bedb72
+pkgver=3.12.0.r96.g3c64fb6
pkgrel=1
pkgdesc='A GTK+ based e-mail client - git checkout'
arch=('i686' 'x86_64')
@@ -12,8 +12,6 @@ depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'co
makedepends=('git' 'spamassassin' 'bogofilter' 'valgrind'
# dependencies for plugins
'libsoup' 'libgdata' 'webkitgtk2' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk')
- #'libchamplain' needed for geolocation plugin, disabled for now
- # most time it's not compatible with current gnome releases
optdepends=('python2: needed for some tools and python plugin'
'perl: needed for some tools and perl plugin'
'spamassassin: adds support for spamfiltering'
@@ -21,9 +19,8 @@ optdepends=('python2: needed for some tools and python plugin'
'libnotify: for notification plugin'
'libcanberra: for notification plugin'
'dbus: for notification plugin'
- 'expat: for rssyl plugin'
- 'libxml2: for fancy html viewer and gdata plugins'
- 'curl: for fancy html viewer, vcalendar, rssyl and spamreport plugins'
+ 'libxml2: for gtkhtml2_viewer and rssyl plugins'
+ 'curl: for gtkhtml2_viewer, vcalendar, rssyl and spamreport plugins'
'libarchive: for archive plugin and various other plugins'
'libytnef: for tnef_parse plugin'
'webkitgtk2: for the fancy webkit html plugin'
@@ -38,14 +35,22 @@ install=claws-mail.install
source=('claws-mail::git://git.claws-mail.org/claws.git'
'http://www.eworm.de/download/linux/claws-timestamp.patch'
'http://www.eworm.de/download/linux/claws-git-version.patch')
+sha256sums=('SKIP'
+ 'bbf29f10602a74d73f1a30d791ae49c3b1d5abf20c48db0f4c81b0dca7bc0078'
+ 'd377a7a6278b84152cbb8095461223829c3a21e2ca2f35aa8862c058540b61d5')
pkgver() {
cd claws-mail/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
fi
}
@@ -89,6 +94,7 @@ build() {
--enable-pgpmime-plugin \
--enable-spamassassin-plugin \
--enable-bogofilter-plugin \
+ --enable-appdata
#--help
make
@@ -110,6 +116,3 @@ package() {
done
}
-sha256sums=('SKIP'
- 'bbf29f10602a74d73f1a30d791ae49c3b1d5abf20c48db0f4c81b0dca7bc0078'
- 'd377a7a6278b84152cbb8095461223829c3a21e2ca2f35aa8862c058540b61d5')