summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSauyon Lee2015-08-06 17:35:54 +0900
committerSauyon Lee2015-08-06 17:35:54 +0900
commit40be168a7472b2426ce51f794efb4a472220e75e (patch)
tree5020c8b8ce134a5f8419c908e4294d75cf525fb9 /PKGBUILD
parent6d8aaec3e80a51864ec842d0975528732c2f9ebe (diff)
downloadaur-40be168a7472b2426ce51f794efb4a472220e75e.tar.gz
update to 1.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db6aa58a4742..d983558a83ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Sauyon Lee <sauyonl@sauyon.com>
# Contributor: Marc Plano-Lesay <marc.planolesay@gmail.com>
+# Contributor: mexus
pkgname=cldoc
-pkgver=1.7
+pkgver=1.9
pkgrel=1
pkgdesc='cldoc is a clang based documentation generator for C and C++. cldoc tries to solve the issue of writing C/C++ software documentation with a modern, non-intrusive and robust approach.'
arch=('i686' 'x86_64')
@@ -11,18 +12,17 @@ depends=('python2' 'python2-pyparsing')
makedepends=('ruby-sass' 'npm')
options=(!emptydirs)
source=("$pkgname-$pkgver::https://github.com/jessevdk/cldoc/archive/v${pkgver}.tar.gz")
-md5sums=('78742b82c2d0f4c68c886a8346c70f52')
+md5sums=('fada948e1ce7cd0aa1fa330a2fdd256d')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- npm install coffee-script inliner --python=python2
+ npm install coffee-script@1.9.2 inline-source@4.0.1 --python=python2
}
build() {
cd "$srcdir/$pkgname-$pkgver"
python2 setup.py generate \
- --coffee=node_modules/.bin/coffee \
- --inliner=node_modules/.bin/inliner
+ --coffee=node_modules/.bin/coffee
}
package() {