summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzan2020-07-20 18:26:39 -0400
committerzan2020-07-20 18:26:39 -0400
commit8c3b57453b61c08aade185d911597f4b23bb7815 (patch)
treed9e7cdd6ea7ab66095296af0225c887bce6742eb /PKGBUILD
parent42fdc216d5ca5a42ccc11f08337dc83734b8cc7f (diff)
downloadaur-8c3b57453b61c08aade185d911597f4b23bb7815.tar.gz
Apply patch to fix upstream issue 6401
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3898dc1c0ffa..95a5be7109f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,14 +25,21 @@ optdepends=('libcdio: for CD support'
conflicts=(clementine)
provides=(clementine)
_name=Clementine
-source=("git+https://github.com/clementine-player/$_name.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/clementine-player/$_name.git"
+ "close-fix.diff")
+sha256sums=('SKIP'
+ '587c3724483825c2101fc15b8ef3b04b15a4dee34457285f94da6dd9b6db656c')
pkgver() {
cd $_name
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $_name
+ patch -p1 -i $srcdir/close-fix.diff
+}
+
build() {
cmake -B build -S $_name -DENABLE_SPOTIFY_BLOB=off
cmake --build build