summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobozzz2015-09-17 21:06:56 +0200
committerChocobozzz2015-09-17 21:12:12 +0200
commitdf985fd5b8a305b29a3ff0f61097b735d87d1774 (patch)
tree407a05fc6e8e6c97019655461448acde015e0f6d /PKGBUILD
parent75c34b327fa3f7fae14ccbffad054b60b9efadc4 (diff)
downloadaur-df985fd5b8a305b29a3ff0f61097b735d87d1774.tar.gz
Update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a7b10ba58db..a62acecac45c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,26 +8,30 @@ pkgdesc="Experimental Qt5 version of Clementine, a modern music player and libra
arch=('i686' 'x86_64')
license=('GPL')
depends=('gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly'
- 'gst-libav' 'taglib' 'glew' 'liblastfm-qt5' 'libgpod' 'desktop-file-utils'
- 'libmtp' 'libplist' 'hicolor-icon-theme' 'qt5-base' 'sparsehash'
- 'libechonest-qt5' 'libcdio' 'protobuf' 'crypto++' 'chromaprint'
- 'libmygpo-qt5-git' 'qt5-tools' 'qt5-x11extras')
-makedepends=('git' 'boost' 'cmake' 'mesa')
+ 'gst-libav' 'taglib' 'glew' 'desktop-file-utils' 'hicolor-icon-theme'
+ 'qt5-base' 'libechonest-qt5' 'protobuf' 'crypto++' 'chromaprint'
+ 'libmygpo-qt5-git' 'qt5-x11extras')
+makedepends=('git' 'boost' 'cmake' 'mesa' 'qt5-tools')
install=clementine.install
-# Uncomment next lines to enable more features
-#makedepends+=('libspotify' 'libgpod' 'libimobiledevice')
-#optdepends+=(
-#'libspotify: for Spotify support'
-#'libimobiledevice: for iPhone and iPod Touch support'
-#)
+# Uncomment next lines to enable all the features
+#depends+=('libspotify' 'libgpod' 'liblastfm-qt5' 'sparsehash' 'libcdio' 'libmtp' 'fftw')
+optdepends=(
+ 'libspotify: for Spotify support'
+ 'libgpod: for iPhone and iPod Touch support'
+ 'liblastfm-qt5: for LastFM support'
+ 'sparsehash: for cloud support (Dropbox, Google Drive...)'
+ 'libcdio: for CD support'
+ 'libmtp: for MTP support'
+ 'fftw: for moodbar support'
+)
url="http://www.clementine-player.org/"
source=('git+https://github.com/clementine-player/Clementine.git#branch=qt5')
sha256sums=('SKIP')
provides=('clementine')
-conflicts=('clementine')
-replaces=('clementine')
+conflicts=('clementine clementine-lxqt clementine-git')
+replaces=('clementine clementine-lxqt clementine-git')
pkgver() {