summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Weiss2018-10-20 11:25:15 +0200
committerLuca Weiss2018-10-20 11:33:16 +0200
commit4b930f8dc91807d409d2dc6e319632715f2cf28a (patch)
treede39e8ea75b9507d274bf778c0eec8fc1a4bd381 /PKGBUILD
parent7a79ba896a719ad226872406f4c41683cf6c428c (diff)
downloadaur-4b930f8dc91807d409d2dc6e319632715f2cf28a.tar.gz
Modernize package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3e2133a7bbf..fd3782b200de 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,32 @@
# Maintainer: Marcin Tydelski <marcin.tydelski@gmail.com>
# Contributor: Brian Douglass <https://github.com/bhdouglass/, http://bhdouglass.com/>
-pkgname=clickable
-pkgver=272.c18271a
+_pkgname=clickable
+pkgname=$_pkgname-git
+pkgver=5.0.0.r2.g6015551
pkgrel=1
-_gitname=clickable
pkgdesc='Compile, build, and deploy Ubuntu Touch click packages all from the command line.'
arch=('i686' 'x86_64')
-url='https://github.com/bhdouglass/clickable'
+url='https://gitlab.com/clickable/clickable'
license=('GPL3')
-depends=('python' 'docker' 'python-cookiecutter' 'android-tools')
-optdepends=('lxd')
+depends=('python-cookiecutter' 'docker' 'android-tools')
makedepends=('git')
-provides=("${pkgname%}")
-conflicts=("${pkgname%}")
-install="${pkgname%-*}.install"
-source=('git+https://github.com/bhdouglass/clickable.git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('git+https://gitlab.com/clickable/clickable.git')
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd $_pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
-
-mkdir -p $pkgdir/usr/bin $pkgdir/usr/lib/python3.7/site-packages/
-install -m755 -t $pkgdir/usr/bin/ $srcdir/$pkgname/clickable-dev
-mv $pkgdir/usr/bin/clickable-dev $pkgdir/usr/bin/clickable
-cp -R $srcdir/$pkgname/clickable $pkgdir/usr/lib/python3.7/site-packages/
+build() {
+ cd $_pkgname
+ python setup.py build
}
-# vim: ts=2 sw=2 et:
+package() {
+ cd $_pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}