summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortydell2018-04-04 02:21:14 +0200
committertydell2018-04-04 02:21:14 +0200
commit7b36e97086e85502e4e6f8253cd0b9c00a2a064e (patch)
treedb6e7de56de85310b778e871ed556a9e3ff61073 /PKGBUILD
parenta0e916d223b24d2d14f875a4d628e34885c4c076 (diff)
downloadaur-7b36e97086e85502e4e6f8253cd0b9c00a2a064e.tar.gz
Updated package, cookiecutter needs to be installed by pip2 due to python2 used by clickable
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 057539f91954..010c594a0dbb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Brian Douglass <https://github.com/bhdouglass/, http://bhdouglass.com/>
pkgname=clickable
-pkgver=169.6eae4ca
+pkgver=171.df08be6
pkgrel=1
_gitname=clickable
pkgdesc='Compile, build, and deploy Ubuntu Touch click packages all from the command line.'
arch=('i686' 'x86_64')
url='https://github.com/bhdouglass/clickable'
license=('GPL3')
-depends=('docker' 'python-cookiecutter')
-optdepends=()
+depends=('python' 'docker' 'pip2pkgbuild')
+optdepends=('android-sdk-platform-tools' 'lxd')
makedepends=('git')
provides=("${pkgname%}")
conflicts=("${pkgname%}")
@@ -25,11 +25,8 @@ pkgver() {
package() {
-install -dm755 ${pkgdir}/opt
-
-rm -R ${srcdir}/${pkgname}/.git*
-cp -R ${srcdir}/${pkgname} ${pkgdir}/opt/${pkgname}
-
+mkdir -p $pkgdir/usr/bin
+install -m755 -t $pkgdir/usr/bin $srcdir/$pkgname/clickable
}
# vim: ts=2 sw=2 et: