summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFederico Di Pierro2020-12-22 21:58:52 +0100
committerFederico Di Pierro2020-12-22 21:58:52 +0100
commit8d7e30c95883ca4abd3509ced4bc0702cb796e47 (patch)
treefefa231e7a46a2892046d6f849e5869ef268e4fd /PKGBUILD
parentf0516aed132f36520e2840c978ddc4372ced1193 (diff)
downloadaur-8d7e30c95883ca4abd3509ced4bc0702cb796e47.tar.gz
Small PKGBUILD fixes ported from clightd 5.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f13890d8cfaf..bdec3ef98448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=clightd
_gitname=Clightd
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bus interface to change screen brightness and capture frames from webcam."
arch=('i686' 'x86_64')
url="https://github.com/FedeDP/${_gitname}"
license=('GPL')
-depends=('systemd>=221' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit' 'ddcutil>=0.9.5' 'libmodule>=5.0.0')
+depends=('systemd>=221' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit' 'ddcutil>=0.9.5' 'libmodule>=5.0.0' 'libjpeg-turbo' 'libusb' 'libdrm' 'wayland')
makedepends=('git' 'cmake')
optdepends=('clight: user service to automagically change screen backlight matching ambient brightness.')
provides=('clightd')
@@ -27,8 +27,9 @@ build() {
-G "Unix Makefiles" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib/"$_gitname" \
-DCMAKE_BUILD_TYPE="Release" \
- -DENABLE_DDC=1 -DENABLE_GAMMA=1 -DENABLE_DPMS=1 -DENABLE_SCREEN=1 \
+ -DENABLE_DDC=1 -DENABLE_GAMMA=1 -DENABLE_DPMS=1 -DENABLE_SCREEN=1 -DENABLE_YOCTOLIGHT=1 \
..
make
}