summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Scheirer2015-06-15 23:44:26 -0400
committerMatt Scheirer2015-06-15 23:44:26 -0400
commit8a889b16f1a7d6945f21cc10eca4a75bf9e5bd6d (patch)
tree0859db7f76c13027df80cd9aeffac2516030acea /PKGBUILD
downloadaur-8a889b16f1a7d6945f21cc10eca4a75bf9e5bd6d.tar.gz
Port to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a839eada6f34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Zanny <lordzanny@gmail.com>
+
+pkgname=clinfo
+pkgver=2.0.15.03.24
+pkgrel=1
+pkgdesc="Print all known information about all available OpenCL platforms and devices in the system"
+arch=(i686 x86_64)
+url="https://github.com/Oblomov/clinfo"
+license=('custom:Public Domain')
+depends=(libcl)
+makedepends=(opencl-headers)
+provides=(clinfo)
+conflicts=(clinfo)
+replaces=(clinfo)
+source=(git+https://github.com/oblomov/clinfo.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ echo $(git describe --tags | cut -f1 -d"-")
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -D -m755 clinfo "${pkgdir}/usr/bin/clinfo"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 man/clinfo.1 "${pkgdir}/usr/share/man/man1/clinfo.1"
+} \ No newline at end of file