summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2016-02-17 15:07:42 +0100
committerEduardo Sánchez Muñoz2016-02-17 15:07:42 +0100
commitd1c5c8f1681382b3e883ff44af460e24cc3d5bfc (patch)
treeb99fe385eab3d6988437807b0b5dc3a211c37857 /PKGBUILD
parent0e35302e3600b6eef001068927b4ca2dfcf2725a (diff)
downloadaur-d1c5c8f1681382b3e883ff44af460e24cc3d5bfc.tar.gz
Add Jupyter kernel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 23 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e81184a6fac..747fd2e81164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Eduardo Sánchez Muñoz
-pkgname=cling-git
-pkgver=r2795.7644a68
+pkgname=(cling-git cling-jupyter-git)
+pkgver=r2850.a754fcc
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
url="https://root.cern.ch/cling"
license=('custom:Cling Release License')
-depends=('libffi')
-makedepends=('cmake' 'libffi' 'git' 'python2')
-options=()
-conflicts=()
-provides=()
+makedepends=('cmake' 'libffi' 'git' 'python2' 'jupyter' 'python-pip')
source=("llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
"clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches"
- "cling::git+http://root.cern.ch/git/cling.git#branch=master")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+ "cling::git+http://root.cern.ch/git/cling.git#branch=master"
+ "cling-jupyter-path.diff")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '2d601fe5c75388a0c9e6cdbef6d15f356ea7b9957c9d56525becf247025a7ed2')
pkgver() {
cd "$srcdir/cling"
@@ -30,6 +30,9 @@ prepare() {
if [ ! -h "$srcdir/llvm/tools/cling" ]; then
ln -s "$srcdir/cling" "$srcdir/llvm/tools/cling"
fi
+
+ cd "$srcdir/cling"
+ git apply "$srcdir/cling-jupyter-path.diff"
}
build() {
@@ -54,7 +57,9 @@ build() {
make -C tools/cling
}
-package() {
+package_cling-git() {
+ depends=('libffi')
+
cd "$srcdir/cling-build"
make -C tools/clang DESTDIR="$pkgdir" install
make -C tools/cling DESTDIR="$pkgdir" install
@@ -64,3 +69,11 @@ package() {
install -Dm644 "$srcdir/llvm/tools/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+package_cling-jupyter-git() {
+ depends=('cling-git' 'jupyter')
+
+ cd "$srcdir/cling/tools/Jupyter/kernel"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ jupyter-kernelspec install --prefix="$pkgdir/usr" cling
+}