summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2015-11-12 21:52:36 +0100
committerEduardo Sánchez Muñoz2015-11-12 21:52:36 +0100
commite334df3f7bf6e44e5a2a5f3845fdb64dc329af78 (patch)
treee887328a1a95179e4e45bf06ebd0c7413439d459 /PKGBUILD
parentd6314fcbf2058644a78a69e8178f844be81975dc (diff)
downloadaur-e334df3f7bf6e44e5a2a5f3845fdb64dc329af78.tar.gz
Fix build.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a765f0878a1b..8b661aa4ebae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Eduardo Sánchez Muñoz
pkgname=cling-git
-pkgver=r2663.040bad9
+pkgver=r2704.30cc58a
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
-url="https://root.cern.ch/drupal/content/cling"
+url="https://root.cern.ch/cling"
license=('custom:Cling Release License')
depends=('libffi')
-makedepends=('cmake' 'libffi' 'clang' 'git' 'python2')
+makedepends=('cmake' 'libffi' 'git' 'python2')
options=()
conflicts=()
provides=()
source=("llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
"clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches"
"cling::git+http://root.cern.ch/git/cling.git#branch=master")
-md5sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/cling"
@@ -33,14 +33,13 @@ prepare() {
}
build() {
- cd "$srcdir"
-
mkdir -p "$srcdir/cling-build"
cd "$srcdir/cling-build"
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/opt/cling" \
+ -DLLVM_TARGETS_TO_BUILD="host" \
-DLLVM_BUILD_LLVM_DYLIB=OFF \
-DLLVM_ENABLE_RTTI=ON \
-DLLVM_ENABLE_FFI=ON \
@@ -50,7 +49,8 @@ build() {
-DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
"$srcdir/llvm"
- make
+ make -C tools/clang
+ make -C tools/cling
}
package() {