summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2019-11-15 21:28:22 -0500
committerAndrew Sun2019-11-15 21:28:22 -0500
commitb16577a74c044dc2f6bf696eccb464c41080d703 (patch)
treea3fbab19ef5907e180d5359829b3b5cf6d249ad8 /PKGBUILD
parent81061f3f3e08180874ed389bad0221d2a3f4baa8 (diff)
downloadaur-b16577a74c044dc2f6bf696eccb464c41080d703.tar.gz
python 3.8 fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f90c751b42a..7576d167acc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,17 @@ license=('MIT')
depends=('lua' 'python')
makedepends=('clang' 'cmake' 'git' 'ninja' 're2c')
conflicts=('clasp')
-source=("git+https://github.com/potassco/clingo#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://github.com/potassco/clingo#tag=v${pkgver}"
+ "python38-fix.patch")
+sha256sums=('SKIP'
+ '782d9fa710e59cba36bc3bfb922d52de0469cd3d0c5c591308f8e459139bd72f')
prepare() {
sed '/#include <xlocale.h>/d' -i "${srcdir}"/clingo/clasp/libpotassco/src/string_convert.cpp
+
+ cd "${srcdir}/${pkgname}"
+ # Upstream patch
+ patch -Np1 -i "${srcdir}/python38-fix.patch"
}
build() {