summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkikadf2018-06-05 16:46:53 +0200
committerkikadf2018-06-05 16:46:53 +0200
commit2e45b8fd821ad42012ef60cedf87022fbc6d3a7c (patch)
treeaee107b320af19bb7157b6b5b8d2958fecfcb7bf /PKGBUILD
parentfdf24f8d41c96916c180ef4b1c5a358ea391dc6d (diff)
downloadaur-2e45b8fd821ad42012ef60cedf87022fbc6d3a7c.tar.gz
Use official release with the Qt5 compatible patch, drop fork to fix lincennceissue. Only maintain the qt5 patches.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b24a2001a9c..c0a248bc8c95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,33 @@
pkgname=clipgrab-qt5
pkgver=3.6.8
-pkgrel=1
-pkgdesc='Fork of ClipGrab to make it compatible with Qt5'
+pkgrel=2
+pkgdesc='A video downloader and converter for YouTube, Veoh, DailyMotion, MyVideo, ... (Qt5)'
arch=('i686' 'x86_64')
-url='https://github.com/OpenHelios/clipgrab-qt5'
+url='http://clipgrab.org'
license=(GPL3)
depends=('qt5-webkit')
optdepends=('ffmpeg: for the conversion functionality')
-makedepends=('git')
-#source=($pkgname::git+https://github.com/OpenHelios/clipgrab-qt5.git
-source=(https://github.com/kikadf/clipgrab-qt5/archive/${pkgver}.tar.gz
- $pkgname.desktop)
-md5sums=('ddb16609f2f34873098b809f83c6438b'
- '86ec4e7907a20dcae2c0cf6ad2438632')
+source=(https://download.clipgrab.org/clipgrab-$pkgver.tar.gz
+ $pkgname.desktop
+ https://gitlab.com/kikadf/clipgrab-qt5/raw/patch/patch/clipgrab-qt5-${pkgver}.patch)
+md5sums=('43273a4fd34e77fa85970156e1e25561'
+ '86ec4e7907a20dcae2c0cf6ad2438632'
+ '0b0406911f06585cf11eff3444eb4ceb')
+
+prepare() {
+ cd clipgrab-$pkgver
+ patch -p1 -i ../clipgrab-qt5-${pkgver}.patch
+}
build() {
- cd $pkgname-$pkgver
+ cd clipgrab-$pkgver
qmake clipgrab.pro
make
}
package() {
- cd $pkgname-$pkgver
+ cd clipgrab-$pkgver
install -Dm755 clipgrab "$pkgdir/usr/bin/$pkgname"
install -Dm644 icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"