summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMubashir Haroon2021-04-17 11:25:27 +0500
committerMubashir Haroon2021-04-17 11:25:27 +0500
commit61e8a309741094cb9fa18bb6fc278ef4940a1c10 (patch)
treee3421c6b5d5855b40ffff599868778139ae227be /PKGBUILD
downloadaur-61e8a309741094cb9fa18bb6fc278ef4940a1c10.tar.gz
initial commit of clipman-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9c289ecf9c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mubashir Haroon <mubashirmusab at gmail dot com>
+# Contributor: Husam Bilal <me@husam.dev>
+
+_pkgname=clipman
+pkgname=clipman-git
+pkgver=v1.4.0.r22.g505d7e4
+pkgrel=1
+pkgdesc="A simple clipboard manager for Wayland"
+url="https://github.com/yory8/clipman"
+depends=("wl-clipboard>=2.0")
+makedepends=("go" "git")
+provides=("clipman")
+conflicts=("clipman")
+license=("GPL3")
+arch=("x86_64" "i686")
+md5sums=("SKIP")
+source=("${_pkgname}::git+https://github.com/yory8/${_pkgname}.git")
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ go build .
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 $_pkgname $pkgdir/usr/bin/$_pkgname
+ install -Dm644 docs/$_pkgname.1 $pkgdir/usr/share/man/man1/$_pkgname.1
+ gzip $pkgdir/usr/share/man/man1/$_pkgname.1
+}