summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreg Hurrell2021-08-05 15:35:47 +0200
committerGreg Hurrell2021-08-05 15:37:46 +0200
commit72d2812882bab9c456eed686b6cecc37e9adc622 (patch)
tree176689b626491fe965051bb30f9b4493cfbdf323 /PKGBUILD
parentf08fc825d9e44fc9418ab1cdb8be4e0b0e6dc448 (diff)
downloadaur-72d2812882bab9c456eed686b6cecc37e9adc622.tar.gz
fix: update broken patch
I think this has been broken for a while. The old patch was a patch-against-a-patched version of the software, not a patch against a pristine version of the upstream source.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a434e3423b4b..a1c81bdf132b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Greg Hurrell <greg@hurrell.net>
pkgname=clipper-git
-pkgver=2.0.0_20_g3ab426d
-pkgrel=2
+pkgver=2.0.0_11_gecb7766
+pkgrel=1
pkgdesc="Clipboard access for local and remote tmux sessions"
arch=(x86_64)
url="https://github.com/wincent/clipper"
@@ -14,18 +14,16 @@ makedepends=(
optdepends=('xclip: access to X11 clipboard')
source=(
"${pkgname}::git+https://github.com/wincent/clipper.git"
- "service-path.patch"
-)
-sha256sums=(
- 'SKIP'
- 'e9f238ab3619091b3e191570f4cee46ecb56063d77dc7677bbe6f5b1013b901a'
+ "service.patch"
)
+sha256sums=('SKIP'
+ '5cdc4f5262ca69c8530813e6a4b2555cf2b30d8c6489d45a16b7d94f1655a354')
prepare() {
cd "$pkgname"
echo "$LDFLAGS"
- git reset --hard master
- patch --strip 1 --input="${srcdir}/service-path.patch"
+ git reset --hard main
+ patch --strip 1 --input="${srcdir}/service.patch"
}
pkgver() {
@@ -44,7 +42,7 @@ check() {
package() {
cd "$pkgname"
- LDFLAGS="-extldflags \"${LDFLAGS}\"" make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm755 clipper "$pkgdir/usr/bin/clipper"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/clipper-git/LICENSE"
install -Dm644 contrib/linux/systemd-service/clipper.service "$pkgdir/usr/share/clipper/clipper.service"
echo