summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreg Hurrell2020-12-08 01:27:49 +0100
committerGreg Hurrell2020-12-08 01:27:49 +0100
commitf08fc825d9e44fc9418ab1cdb8be4e0b0e6dc448 (patch)
tree6222b74e3af2507a6be8201e4eb291e4017650d4 /PKGBUILD
parent6416486f61f6f4f77748351d48ecf981f37e52a0 (diff)
downloadaur-f08fc825d9e44fc9418ab1cdb8be4e0b0e6dc448.tar.gz
refactor: store sample service file under /usr/share
Because with the previous version, root would end up running the service, which isn't very useful; instead, users need to run a local copy. We emit instructions during `package()` so they can see what they need to do.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ae0e5a65c30..a434e3423b4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Greg Hurrell <greg@hurrell.net>
pkgname=clipper-git
-pkgver=2.0.0_15_ge6fd460
-pkgrel=1
+pkgver=2.0.0_20_g3ab426d
+pkgrel=2
pkgdesc="Clipboard access for local and remote tmux sessions"
arch=(x86_64)
url="https://github.com/wincent/clipper"
@@ -18,7 +18,7 @@ source=(
)
sha256sums=(
'SKIP'
- '2295aa32f28f1aeeec1ddb375fd8bf0e138d58f239bc00634df7d1f71b04ba5e'
+ 'e9f238ab3619091b3e191570f4cee46ecb56063d77dc7677bbe6f5b1013b901a'
)
prepare() {
@@ -45,6 +45,17 @@ check() {
package() {
cd "$pkgname"
LDFLAGS="-extldflags \"${LDFLAGS}\"" make DESTDIR="$pkgdir" PREFIX=/usr install
- install -Dm644 contrib/linux/systemd-service/clipper.service "$pkgdir/usr/lib/systemd/system/clipper.service"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/clipper-git/LICENSE"
+ install -Dm644 contrib/linux/systemd-service/clipper.service "$pkgdir/usr/share/clipper/clipper.service"
+ echo
+ echo "A sample systemd service has been installed to /usr/share/clipper/clipper.service"
+ echo
+ echo "To use it:"
+ echo
+ echo " mkdir -p ~/.config/systemd/user"
+ echo " cp /usr/share/clipper/clipper.service ~/.config/systemd/user/clipper.service"
+ echo " systemctl --user daemon-reload"
+ echo " systemctl --user enable clipper.service"
+ echo " systemctl --user start clipper.service"
+ echo
}