summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-09-07 08:20:52 -0600
committerMark Wagie2021-09-07 08:20:52 -0600
commit436a3e2575cb121f360a6d4d8ac1c8d75264b565 (patch)
tree027dc50f59dfdaea41b2dfceba605285277d1bed /PKGBUILD
parent4b28b68bb4e031c16d03eb56010ce597df886e30 (diff)
downloadaur-436a3e2575cb121f360a6d4d8ac1c8d75264b565.tar.gz
use Electron 13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a71b69eb70e2..b712a3188f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clipto-bin
pkgver=5.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=('electron')
+depends=('electron13')
optdepends=('libnotify: for desktop notifications'
'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
@@ -15,26 +15,26 @@ replaces=("${pkgname%-bin}.pro")
source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
"${pkgname%-bin}")
sha256sums=('a89aab8504bbe55a581bac943ef9461fb95fb403356a5021cfd5756e6da698f4'
- '9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635')
+ '992432bb07bdc6f3ac2551d7ec923a59bd649141c458112a969f4994dea2ecf1')
prepare() {
- chmod +x "${pkgname%-bin}-$pkgver.AppImage"
- ./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
+ chmod +x "${pkgname%-bin}-$pkgver.AppImage"
+ ./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
- sed -i 's|Exec=AppRun|Exec=clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+ sed -i 's|Exec=AppRun|Exec=clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- cd "$srcdir/squashfs-root"
- find {locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
+ cd "$srcdir/squashfs-root"
+ find {locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
- install -d "$pkgdir/usr/lib/${pkgname%-bin}"
- cp -r resources "$pkgdir/usr/lib/${pkgname%-bin}"
+ install -d "$pkgdir/usr/lib/${pkgname%-bin}"
+ cp -r resources "$pkgdir/usr/lib/${pkgname%-bin}"
- install -Dm755 "$srcdir/${pkgname%-bin}" -t "$pkgdir/usr/bin"
+ install -Dm755 "$srcdir/${pkgname%-bin}" -t "$pkgdir/usr/bin"
- install -Dm644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
- install -d "$pkgdir/usr/share/icons"
- cp -r usr/share/icons/hicolor "$pkgdir/usr/share/icons"
+ install -d "$pkgdir/usr/share/icons"
+ cp -r usr/share/icons/hicolor "$pkgdir/usr/share/icons"
}