summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-06-23 09:39:19 -0600
committerMark Wagie2020-06-23 09:39:19 -0600
commitbca3f5f828288b3f62796ff04b60eddcdf61d6e4 (patch)
tree497166523714b32161c3812e1bc11d50d2673adc /PKGBUILD
parentb33d6ef3c196150e425db24e03c2ebe4531c55e7 (diff)
downloadaur-bca3f5f828288b3f62796ff04b60eddcdf61d6e4.tar.gz
updated to 2.9.1, use system electron
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e7d96fcc6ac..3eb2fd589208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clipto-bin
-pkgver=2.9.0
-pkgrel=1
+pkgver=2.9.1
+pkgrel=2
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=('nss' 'libxss' 'libxtst' 'libappindicator-gtk3' 'libnotify')
+depends=('electron')
+optdepends=('libnotify: for desktop notifications'
+ 'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}" "${pkgname%-bin}.pro")
replaces=("${pkgname%-bin}.pro")
source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
"${pkgname%-bin}")
-sha256sums=('622dd5af4e361577128aa856722e283941a250613d8c31ce1ba0fdce7a6fef42'
- 'a68ea565595fca737ff54b7a29e04f5059e5897955ab15c09ca9f36eb70fcfdb')
+sha256sums=('31b274d91007b5216004616f59369f1f93db7943432a68472f8f72c0467c881b'
+ '9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635')
prepare() {
chmod +x "${pkgname%-bin}-$pkgver.AppImage"
./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
- sed -i 's|Exec=AppRun|Exec=/opt/clipto/clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+ sed -i 's|Exec=AppRun|Exec=clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
}
package() {
find squashfs-root/{locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
- install -d "$pkgdir/opt/${pkgname%-bin}"
- cp -r squashfs-root/* "$pkgdir/opt/${pkgname%-bin}"
- rm -rf "$pkgdir/opt/${pkgname%-bin}/usr"
- rm "$pkgdir/opt/${pkgname%-bin}"/{"${pkgname%-bin}".desktop,AppRun}
+ install -d "$pkgdir/usr/lib/${pkgname%-bin}"
+ cp -r squashfs-root/resources "$pkgdir/usr/lib/${pkgname%-bin}"
install -Dm755 "${pkgname%-bin}" -t "$pkgdir/usr/bin"