summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÉtienne Deparis2019-06-07 12:22:38 +0200
committerÉtienne Deparis2019-06-07 12:22:38 +0200
commit05763f9788b7e00f89bc6bbf052f3042a55e710b (patch)
tree30cff75cae8e7cc3b2d5c0b28acc5abcc7f11bc2 /PKGBUILD
parentb6eb570809b9063302794e56c43ad25f49727b03 (diff)
downloadaur-05763f9788b7e00f89bc6bbf052f3042a55e710b.tar.gz
1.27.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9c54f947dcf..f4d639345904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
# french pkgbuild here: https://git.deparis.io/pkgbuilds/tree/cliqz_work/PKGBUILD?id=17ec1716c90dd08
pkgname=cliqz
_pkgname=browser-f
-pkgver=1.26.5
+pkgver=1.27.0
pkgrel=1
_cqzchannel=release
-#_cqzbuildid=$(curl "http://repository.cliqz.com.s3.amazonaws.com/dist/${_cqzchannel}/${pkgver}/lastbuildid")
-_cqzbuildid=20190507112044
+_cqzbuildid=$(curl "http://repository.cliqz.com.s3.amazonaws.com/dist/${_cqzchannel}/${pkgver}/lastbuildid")
+#_cqzbuildid=20190507112044
pkgdesc="Firefox-based privacy aware web browser, build from sources"
arch=(i686 x86_64)
url="https://cliqz.com/"
@@ -20,13 +20,13 @@ depends=(gtk3 libxt startup-notification mime-types dbus-glib ffmpeg nss
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake
inetutils xorg-server-xvfb autoconf2.13 rust clang llvm
jack gtk2 python nodejs python2-psutil cbindgen nasm libnotify
- wget pulseaudio rsync)
+ wget pulseaudio rsync gconf)
optdepends=('hunspell-en_US: Spell checking, American English')
conflicts=(cliqz-bin)
source=("https://github.com/cliqz-oss/browser-f/archive/$pkgver.tar.gz"
- '0001-bz-1468911.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-bz-1468911.patch?h=packages/firefox&id=3d978bec03d20c51d60844ac29a769f4fff1ec5e')
-sha256sums=('934c24e74bd601a3a276e82a2e4bcd8faecde34997fc4f1b160dd3a0efb0cea2'
- '821f858bac2e13ce02b8c20d5387d4ecc8ab2d0e4ebe0a517cbf935da6aeb31b')
+ '0001-bz-1521249.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-bz-1521249.patch?h=packages/firefox&id=e58550cb74099902903a8514d9a54e7060259bac')
+sha256sums=('8a8b28dcf31b58e945d02df9ce320daf86d8a718109a55bb2848d319e64c5fe4'
+ 'd0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c')
options=(!emptydirs !makeflags)
prepare() {
@@ -61,7 +61,7 @@ END
cd "$srcdir/${_pkgname}-$pkgver/mozilla-release"
# https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
- patch -Np1 -i "$srcdir/0001-bz-1468911.patch"
+ patch -Np1 -i "$srcdir/0001-bz-1521249.patch"
# Remove -lcrmf from old configure scripts
sed -i 's/NSS_LIBS="$NSS_LIBS -lcrmf"/NSS_LIBS="$NSS_LIBS"/' old-configure.in