summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEthan Kerrick2023-09-11 22:49:37 -0400
committerEthan Kerrick2023-09-11 22:49:37 -0400
commit01704dde6b3f5ef23f294ffd26c323c6e05728e7 (patch)
treeed3f5abd012505ce84644a54560963d97b57e767 /PKGBUILD
parentcec76b8bb2a316a799b1daadfdf9e3edfc1b83b3 (diff)
downloadaur-01704dde6b3f5ef23f294ffd26c323c6e05728e7.tar.gz
updated to 2023-09-10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 730a1c1bcdec..1c4e69ee2d94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: silverhikari <kerrickethan@gmail.com>
pkgname=clk-sdl
-pkgver=2023_05_15
-pkgrel=2
+pkgver=2023_09_10
+pkgrel=1
epoch=
pkgdesc="a latency hating emulator for 8 and 16 bit platforms(sdl version)"
arch=(x86_64)
url="https://github.com/TomHarte/CLK"
license=('MIT')
-depends=('sdl2')
+depends=('sdl2' 'zlib' 'gcc-libs' 'glibc' 'libglvnd')
makedepends=('scons')
provides=('clksignal')
conflicts=('clk-qt' 'clk-qt-git' 'clk-sdl-git')
-source=("https://github.com/TomHarte/CLK/archive/refs/tags/${pkgver//_/-}.tar.gz" "680000-removal.patch")
+source=("https://github.com/TomHarte/CLK/archive/refs/tags/${pkgver//_/-}.tar.gz")
noextract=()
install="clk.install"
-sha256sums=('499b5588936b9ac63864f7399007e8c154a5e08dc4400dd3b7645a90330ae39b' 'SKIP')
+sha256sums=('f431c76864b22e20340768cc09ba3b5565ed17a55bbae54bd2ae79487d292152')
# added even though it can build without unlike qt version, but is here encase their is any underlying issues
-prepare() {
-cd "CLK-${pkgver//_/-}/"
-patch -p1 -i "../680000-removal.patch"
-}
-
build() {
cd "CLK-${pkgver//_/-}/OSBindings/SDL/"
scons