summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2024-03-06 17:28:01 +0100
committerbartus2024-03-06 17:28:01 +0100
commitc4c61ec54d56cbbbdd6a14cd168b35189c42e908 (patch)
tree70d464f3e321aef97e6a904fda22403cc9eff0c5 /PKGBUILD
parent90ab47b2be9cc3fc27bf28af2005d44b65345bc1 (diff)
downloadaur-c4c61ec54d56cbbbdd6a14cd168b35189c42e908.tar.gz
Update deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a162b2a7c369..982047907494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,11 @@ pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
url="http://www.danielgm.net/cc/"
license=('GPL2')
-depends=('cgal' 'fbx-sdk' 'ffmpeg4.4' 'glew' 'glu' 'mesa' 'mpir' 'pcl' 'pdal' 'qt5-base' 'qt5-tools' 'qt5-svg' 'qt5-websockets' 'shapelib' 'tbb' 'opencascade' 'opencv' 'gdal')
+depends=('cgal' 'fbx-sdk' 'ffmpeg4.4' 'glew' 'glu' 'mesa' 'mpir' 'pcl' 'pdal' 'laszip' 'qt5-base' 'qt5-tools' 'qt5-svg' 'qt5-websockets' 'shapelib' 'tbb' 'opencascade' 'opencv' 'gdal')
#fix pcl:>vtk:>vtkm:>openmp missing deps
-depends+=(openmp)
+depends+=(openmpi)
+depends+=(nlohmann-json fmt jsoncpp)
+depends+=(utf8cpp fast_float)
makedepends=('clang' 'cmake' 'doxygen' 'git' 'laz-perf' 'libharu' 'ninja' 'proj' 'python')
conflicts=('cloudcompare')
provides=('cloudcompare')
@@ -82,7 +84,7 @@ build() {
-DPLUGIN_IO_QFBX:BOOL=ON # requires update of AUR/fbx-sdk (https://www.autodesk.com/content/dam/autodesk/www/adn/fbx/2020-1-1/fbx202011_fbxsdk_linux.tar.gz)
-DFBX_SDK_INCLUDE_DIR:PATH=/usr/include
-DFBX_SDK_LIBRARY_FILE:FILEPATH=/usr/lib/libfbxsdk.so
- -DPLUGIN_IO_QPDAL:BOOL=ON
+ -DPLUGIN_IO_QLAS:BOOL=ON
-DPLUGIN_IO_QPHOTOSCAN:BOOL=ON
-DPLUGIN_IO_QRDB:BOOL=OFF # requires rdblib (package for AUR from http://www.riegl.com/products/software-packages/rdblib/)
-DPLUGIN_IO_QSTEP=ON # requires opencascade