summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgithub-actions[bot]2023-11-17 23:53:00 +0000
committergithub-actions[bot]2023-11-17 23:53:00 +0000
commit05e3ff0415fe89a2e7f1033114103c86b49faba8 (patch)
tree5287fe984bf0d593593e810b5266634389151faa /PKGBUILD
parent52e8e7b421ccbd623d431b9cd63df4ce6bea6d29 (diff)
downloadaur-05e3ff0415fe89a2e7f1033114103c86b49faba8.tar.gz
Automatic update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0566ad4cb2c6..156a22ef1d2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=cloudflare-dynamic-dns
pkgver=2.3.2
-pkgrel=10
+pkgrel=11
pkgdesc='Updates AAAA records at Cloudflare according to the current IPv6 address'
url='https://github.com/zebradil/cloudflare-dynamic-dns'
arch=(any)
@@ -35,16 +35,11 @@ check ()
}
package ()
{
- cd "$pkgname-$pkgver" || exit 1;
+ set -eo pipefail;
+ cd "$pkgname-$pkgver";
BIN="build/$pkgname";
install -Dm755 "$BIN" -t "$pkgdir/usr/bin";
install -Dm644 systemd/* -t "$pkgdir/usr/lib/systemd/system";
- install -m700 -d "$pkgdir/etc/$pkgname/config.d";
- mkdir -p "$pkgdir/usr/share/bash-completion/completions/";
- mkdir -p "$pkgdir/usr/share/zsh/site-functions/";
- mkdir -p "$pkgdir/usr/share/fish/vendor_completions.d/";
- "./$BIN" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/$pkgname";
- "./$BIN" completion fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/$pkgname.fish";
- "./$BIN" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+ install -m700 -d "$pkgdir/etc/$pkgname/config.d"
}
sha256sums=('2282185f9e9279425e1cedc3ea4fc271bfdf178f5f07154ea1f7123e1ce251a4')