summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTarn W. Burton2020-07-29 14:05:33 -0400
committerTarn W. Burton2020-07-29 14:05:33 -0400
commit7f5086adea3a047d87aa8bcef365fc60e80d0739 (patch)
treecdd924c4abe5a20c4252475a0490df28172358c4 /PKGBUILD
downloadaur-7f5086adea3a047d87aa8bcef365fc60e80d0739.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dadbf7c56d8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tarn W. Burton <twburton@gmail.com>
+pkgname=clpm
+pkgver=0.3.4
+pkgrel=1
+pkgdesc='Common Lisp Package Manager'
+arch=('x86_64')
+license=('BSD')
+url="https://gitlab.common-lisp.net/clpm/clpm"
+depends=('sbcl')
+provides=('clpm')
+source=($pkgname::git+https://gitlab.common-lisp.net/clpm/clpm.git#tag=v${pkgver})
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ git submodule init
+ git submodule update
+ sbcl --script scripts/build.lisp
+}
+
+package() {
+ cd $pkgname
+ INSTALL_ROOT=$pkgdir/usr/ sh install.sh
+}
+