summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSabu Siyad2021-06-02 13:26:43 +0530
committerSabu Siyad2021-06-02 13:26:43 +0530
commiteaf82b24237eab58c682159e1d75d5cc81147c80 (patch)
treeb6298c6b693439b5e54be63a4d0cb971f6dbb986 /PKGBUILD
downloadaur-clubhouse-desktop-bin.tar.gz
Initial upload: clubhouse-desktop-bin 1.0.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..895b72d34606
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sabu Siyad <ssiyad at disroot dot org>
+# This PKGBUILD is maintained at https://github.com/ssiyad/pkgbuilds/
+
+pkgname=clubhouse-desktop-bin
+_pkgname=clubhouse-desktop
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="An unofficial Clubhouse desktop client"
+arch=('x86_64')
+url="https://github.com/callmearta/clubhouse-desktop"
+license=("MIT")
+provides=("clubhouse-desktop")
+source=(
+ "$url/releases/download/${pkgver}/clubhouse-linux-x64.zip"
+ "clubhouse-desktop.sh"
+ "clubhouse-desktop.desktop"
+)
+sha256sums=(
+ "5d6fa337491bce097afa3a4d4b7b0f2a63ccb49f4ad6c717e16202edd785c297"
+ "b3cee2deede1e69172d0b2cc246e0e259675f8c0fd09de339027288aebb224fa"
+ "d088cea66fa7d5f8e99d29b150a33b311131a9c38144f0093ccca9bd633aaa52"
+)
+
+package() {
+ cd ${srcdir}
+ install -Dm755 clubhouse-desktop.sh "${pkgdir}"/usr/bin/"${_pkgname}"
+ install -Dm755 clubhouse-desktop.desktop "${pkgdir}"/usr/share/applications/clubhouse-desktop.desktop
+ mkdir -p "${pkgdir}"/usr/lib/
+ cp -r clubhouse-linux-x64 "${pkgdir}"/usr/lib/"${_pkgname}"
+ install -Dm644 clubhouse-linux-x64/LICENSE "${pkgdir}"/usr/share/licenses/"${_pkgname}"/LICENSE
+}