summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2020-02-18 01:05:06 +0100
committerPellegrino Prevete2020-02-18 01:05:06 +0100
commit637384fc0ced3896594514199ee343f0386df200 (patch)
treee91fa45fec224a419805bd2fe0d8f3d57f7334e7 /PKGBUILD
downloadaur-637384fc0ced3896594514199ee343f0386df200.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b1bc4e4e13b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+
+_pkgname=clutter-gtk
+pkgname=$_pkgname-git
+pkgver=1.8.5+11+ec9239ba
+pkgrel=1
+pkgdesc="Clutter integration with GTK+"
+arch=(x86_64)
+url="https://gitlab.gnome.org/GNOME/clutter-gtk"
+license=(LGPL)
+depends=(clutter)
+makedepends=(gobject-introspection gtk-doc git meson)
+source=("git+https://gitlab.gnome.org/GNOME/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ meson $_pkgname build -Denable_docs=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+# vim:set sw=2 et: