summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2023-08-04 14:33:33 +0200
committerCarl Smedstad2023-08-04 14:33:33 +0200
commit8dadb3a1f70f125d785cffe12e38757df650ce37 (patch)
tree1344c1cfe47b5e375837d674d3cd123697fb02d1 /PKGBUILD
parent031727c97026128b421052e4b99eec5bc4491ab1 (diff)
downloadaur-8dadb3a1f70f125d785cffe12e38757df650ce37.tar.gz
Publish version 1.4.2-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 29 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 099ca042412a..4c1e3b150846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,25 @@
pkgname=cmake-lint
pkgver=1.4.2
-pkgrel=3
+pkgrel=4
pkgdesc="Check for coding style issues in CMake files"
arch=(any)
url="https://github.com/cmake-lint/cmake-lint"
license=(Apache)
+depends=(
+ python
+)
makedepends=(
- python-setuptools
+ python-build
+ python-installer
python-pytest-runner
+ python-setuptools
+ python-wheel
)
-depends=(
- python
+checkdepends=(
+ python-mock
+ python-pytest
+ python-pytest-mock
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
@@ -21,15 +29,29 @@ sha256sums=('bf060987c74e07890f7314a4832c2e54ffb9c5c1e6d799387bc438010f918676')
_archive="$pkgname-$pkgver"
+prepare() {
+ cd "$_archive"
+
+ sed -i '/scripts=/d' setup.py
+}
+
build() {
cd "$_archive"
- python setup.py build
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$_archive"
+
+ python -m pytest \
+ --rootdir="$PWD" \
+ --config-file=/dev/null \
+ --ignore test/cli_test.py
}
package() {
cd "$_archive"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}