summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-15 16:49:08 +0100
committerCarl Smedstad2024-01-15 16:51:45 +0100
commitb1e0ab693a6da78386687b736399b01eb5913c1b (patch)
treecf1def613af43e02d6a2a19f86e8c16a2364a930 /PKGBUILD
parent8dadb3a1f70f125d785cffe12e38757df650ce37 (diff)
downloadaur-b1e0ab693a6da78386687b736399b01eb5913c1b.tar.gz
upgpkg: cmake-lint 1.4.2-5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c1e3b150846..07d0e3d55b6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,12 @@
pkgname=cmake-lint
pkgver=1.4.2
-pkgrel=4
+pkgrel=5
pkgdesc="Check for coding style issues in CMake files"
arch=(any)
url="https://github.com/cmake-lint/cmake-lint"
-license=(Apache)
-depends=(
- python
-)
+license=(Apache-2.0)
+depends=(python)
makedepends=(
python-build
python-installer
@@ -21,7 +19,6 @@ makedepends=(
checkdepends=(
python-mock
python-pytest
- python-pytest-mock
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
@@ -44,10 +41,12 @@ build() {
check() {
cd "$_archive"
- python -m pytest \
- --rootdir="$PWD" \
- --config-file=/dev/null \
- --ignore test/cli_test.py
+ rm -rf tmp_install
+ _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ python -m installer --destdir=tmp_install dist/*.whl
+
+ export PYTHONPATH="$PWD/tmp_install/$_site_packages"
+ pytest --override-ini="addopts="
}
package() {