summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Quirk2015-06-13 08:55:42 +0200
committerRichard Quirk2015-06-13 08:55:42 +0200
commitce7a8c504ca35e3a8648eb92630baaf60a93e6aa (patch)
tree85095b06b69342f8e934b32e238cfe1eaf910de6 /PKGBUILD
downloadaur-ce7a8c504ca35e3a8648eb92630baaf60a93e6aa.tar.gz
Import from aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a1fe14d480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=cmake-lint
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Check for coding style issues in CMake files"
+arch=('any')
+url="http://github.com/richq/cmake-lint/"
+license=('APACHE')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/richq/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0c333de7351e2fc72a4a7bb247ed6712')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python ./setup.py install --prefix=/usr --root="$pkgdir"
+}