summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Di Luigi2015-09-30 01:12:54 +0200
committerWilliam Di Luigi2015-09-30 01:12:54 +0200
commita1034669ab8276996b99eb22771514107725da6e (patch)
treed93d737f8e9dd81a3a4a0b1338acd235479bd8e4 /PKGBUILD
parentd3c82eefffdbd653518cb504c9aeb534bc8adce0 (diff)
downloadaur-a1034669ab8276996b99eb22771514107725da6e.tar.gz
Add testlib dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 084823a657c4..7227b938e71e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('any')
url="http://cms-dev.github.io/"
license=('AGPL3')
depends=(
- 'isolate' 'postgresql' 'postgresql-libs' 'python2' 'iso-codes' 'shared-mime-info'
+ 'isolate' 'testlib' 'postgresql' 'postgresql-libs' 'python2' 'iso-codes' 'shared-mime-info'
)
optdepends=(
'fpc: support for Pascal submissions'
@@ -56,8 +56,9 @@ package() {
# I'm not even sure if this is needed at all
install -d -m770 -g$CMSUSER_GID $pkgdir/var/lib/cms
- # testlib.h
- install -D -m644 cmscontrib/loaders/polygon/testlib.h $pkgdir/usr/include/cms/testlib.h
+ # Fix testlib.h path (maybe patch CMS for this?)
+ install -d -m755 $pkgdir/usr/include/cms
+ ln -s /usr/include/testlib.h $pkgdir/usr/include/cms/testlib.h
# Prepare virtual environment
virtualenv -p python2 $pkgdir/usr/lib/cms/venv