summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorgeRaven2021-05-31 15:21:22 +0100
committerGeorgeRaven2021-05-31 15:21:22 +0100
commit44764ead0e48fe1dd3921e0dbdef20f89d537e46 (patch)
treec1f58d4007aee87bb6fe3c89f1af6e28f6b42104 /PKGBUILD
downloadaur-44764ead0e48fe1dd3921e0dbdef20f89d537e46.tar.gz
Initial commit adding PKGBUILD and .SRCINFO
This commit adds cni-bin PKGBUILD getting the relevant binaries directly from the relevant github release. In particular this package is focused on supporting multiple architectures since the existing packages dont have this, and the easiest way to do this is with a binary package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a1aff23f12d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: GeorgeRaven <GeorgeRavenCommunity at pm dot me>
+pkgname=cni-bin
+pkgdesc="Standardised container networking interface plugins"
+pkgver=0.9.1
+pkgrel=1
+arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
+url="https://www.cni.dev/"
+license=('apache')
+conflicts=('cni')
+provides=('cni=$pkgver')
+_kubectl_file=kubectl-$pkgver
+source=()
+sha256sums=()
+
+case "$CARCH" in
+ arm*) _pkgarch="arm"
+ sha256sums+=('909e800d01cc61ffa26f2629e4a202a58d727e6ccaabd0310ef18d2b1e00943c')
+ ;;
+ aarch64) _pkgarch="arm64"
+ sha256sums+=('ef17764ffd6cdcb16d76401bac1db6acc050c9b088f1be5efa0e094ea3b01df0')
+ ;;
+ x86_64) _pkgarch="amd64"
+ sha256sums+=('962100bbc4baeaaa5748cdbfce941f756b1531c2eadb290129401498bfac21e7')
+ ;;
+esac
+
+source+=(${pkgname}-${pkgver}::"https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-${_pkgarch}-v${pkgver}.tgz")
+
+package() {
+ cd "${srcdir}"
+ unlink "${pkgname}-${pkgver}"
+ mkdir -p "${pkgdir}/opt/cni/bin"
+ install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."
+}