summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorgeRaven2021-09-08 13:02:50 +0100
committerGeorgeRaven2021-09-08 13:02:50 +0100
commit7ea04e9c256ad0aab87f87d61ab0962aa248d5ba (patch)
treeaff0b7c5069411d71baa2db39fe1c4689231f0a3 /PKGBUILD
parent49b6f2ca86945c849895dcd6f0e53784d1ae0b83 (diff)
downloadaur-7ea04e9c256ad0aab87f87d61ab0962aa248d5ba.tar.gz
Updated conflicts with cni-plugins + new note
Added a note to let people know that while the binaries are in the standard location, AND they are in the old location it may still be necessary to point kubelet to the correct directory by modifying the kubelet.env file usually located in /etc/kubernetes/kubelet.env if it does not exist the user should create it with the one line specified in comments.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a6a4e8bc7e6..34a919d46db5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=cni-bin
pkgdesc="Standardised container networking interface"
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
url="https://www.cni.dev/"
license=('apache')
-conflicts=('cni')
+conflicts=('cni' 'cni-plugins')
provides=("cni=${pkgver}")
source=()
sha256sums=()
@@ -34,4 +34,6 @@ package() {
install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."
# also deposit bins in alternate possible location
install -Dm755 "${srcdir}/"* "${pkgdir}/usr/lib/cni"
+ # please ensure kubelet args point to one of these two directories preferably the first
+ # I.E the file `/etc/kubernetes/kubelet.env` should contain something like: KUBELET_ARGS=--cni-bin-dir=/opt/cni/bin
}