summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorgeRaven2022-02-01 08:30:49 +0000
committerGeorgeRaven2022-02-01 08:30:49 +0000
commitc97199cc5095c787bd2caf17686ff382c54cd5ba (patch)
tree723718cb8216b0d45c057111824453dbbd7746cd /PKGBUILD
parent3eabe198a30dd88f66c77030e62b26276a5af68e (diff)
downloadaur-c97199cc5095c787bd2caf17686ff382c54cd5ba.tar.gz
Added .NVCHECKER and updated PKGBUILD
I have added .NVCHECKER config file so for future automation of package bumps. I have also updated the PKGBUILD to use the latest version and with my own style.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 31 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f64d5c82882e..a6e8ada22c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,40 @@
-# Maintainer: ProFfeSsoRr <evvsoft at gmail dot com>
-
+# Maintainer: GeorgeRaven <GeorgeRavenCommunity at pm dot me>
+# Contributor: ProFfeSsoRr <evvsoft at gmail dot com>
pkgname=cni-plugins-bin
-pkgver=0.8.7
+pkgdesc="Container Networking Interface (CNI) Plugins"
+pkgver=1.0.1
pkgrel=1
-pkgdesc="Some CNI network plugins, maintained by the containernetworking team"
-arch=('x86_64' 'aarch64' 'armv7h')
-url="https://github.com/containernetworking/plugins"
+arch=('x86_64' 'aarch64' 'armv7h' 'armv7l')
+url="https://www.cni.dev/"
license=('Apache')
+conflicts=('cni' 'cni-plugins')
+provides=("cni=${pkgver}")
+source=()
+sha256sums=()
-case "${CARCH}" in
- x86_64) _CARCH=amd64 && sha256sums=('7da624010bd2b9fcf47bc30076861166f31ab5936f3b36f199714c7d276a0d12');;
- aarch64) _CARCH=arm64 && sha256sums=('ae13d7b5c05bd180ea9b5b68f44bdaa7bfb41034a2ef1d68fd8e1259797d642f');;
- armv7h) _CARCH=arm && sha256sums=('5757778f4c322ffd93d7586c60037b81a2eb79271af6f4edf9ff62b4f7868ed9');;
+case "$CARCH" in
+ arm*) _pkgarch="arm"
+ sha256sums+=('d35e3e9fd71687fc7e165f7dc7b1e35654b8012995bbfd937946b0681926d62d')
+ ;;
+ aarch64) _pkgarch="arm64"
+ sha256sums+=('2d4528c45bdd0a8875f849a75082bc4eafe95cb61f9bcc10a6db38a031f67226')
+ ;;
+ x86_64) _pkgarch="amd64"
+ sha256sums+=('5238fbb2767cbf6aae736ad97a7aa29167525dcd405196dfbc064672a730d3cf')
+ ;;
esac
-source=("https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-${_CARCH}-v${pkgver}.tgz")
+source+=(${pkgname}-${pkgver}::"https://github.com/containernetworking/plugins/releases/download/v${pkgver}/cni-plugins-linux-${_pkgarch}-v${pkgver}.tgz")
package() {
- cd "$srcdir"
- mkdir -p "$pkgdir"/opt/cni/bin
- install -Dm755 * "$pkgdir"/opt/cni/bin
- rm "$pkgdir"/opt/cni/bin/cni-plugins-linux-${_CARCH}-v${pkgver}.tgz
+ cd "${srcdir}"
+ # get rid of unwanted link
+ unlink "${pkgname}-${pkgver}"
+ # install to default location
+ mkdir -p "${pkgdir}/opt/cni/bin" "${pkgdir}/usr/lib/cni"
+ install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."
+ # also deposit bins in alternate possible location
+ install -Dm755 "${srcdir}/"* "${pkgdir}/usr/lib/cni"
+ # please ensure kubelet args point to one of these two directories preferably the first
+ # I.E the file `/etc/kubernetes/kubelet.env` should contain something like: KUBELET_ARGS=--cni-bin-dir=/opt/cni/bin
}
-
-sha256sums=('977824932d5667c7a37aa6a3cbba40100a6873e7bd97e83e8be837e3e7afd0a8')