summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2016-05-09 16:24:47 +0430
committerBehnam Momeni2016-05-09 16:24:47 +0430
commit16e0934de0de77ca426d72a3ff2acdfec2aec521 (patch)
treed4106beaf8f593d46047c5bc7be925e1baaa0843 /PKGBUILD
parent75e8b2f3ad34ec71c28da5bacdd594d1fb0814e1 (diff)
downloadaur-16e0934de0de77ca426d72a3ff2acdfec2aec521.tar.gz
symlinking individual files instead of the bjlib folder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f61d297cfc4..ceb4397c5ace 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=('cnijfilter-common')
_pkgname=cnijfilter
pkgver=4.00
-pkgrel=2
+pkgrel=3
_pkgreview=1
pkgdesc="Canon IJ Printer Driver (Common Package)"
@@ -19,11 +19,11 @@ license=('custom')
conflicts=('lib32-cnijfilter320')
-makedepends_x86_64=('gcc-multilib' 'lib32-popt')
-depends_x86_64=('lib32-libcups' 'lib32-popt')
+makedepends_x86_64=('gcc-multilib')
+depends_x86_64=('lib32-libcups' 'lib32-popt' 'lib32-libusb' 'lib32-libxml2')
-makedepends_i686=('gcc' 'popt')
-depends_i686=('libcups' 'popt')
+makedepends_i686=('gcc')
+depends_i686=('libcups' 'popt' 'libusb' 'libxml2')
makedepends=('autoconf>=2.13' 'automake>=1.6' 'tar' 'make')
@@ -64,8 +64,8 @@ package() {
install -s -m 755 com/libs_bin32/lib*.so.* ${pkgdir}/usr/lib32
install -D LICENSE-cnijfilter-${pkgver}EN.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-cnijfilter-${pkgver}EN.txt
if [ "${CARCH}" = 'x86_64' ]; then
- install -d ${pkgdir}/usr/lib
- ln -s /usr/lib32/bjlib ${pkgdir}/usr/lib/bjlib
+ install -d ${pkgdir}/usr/lib/bjlib
+ ln -rs ${pkgdir}/usr/lib32/bjlib/* ${pkgdir}/usr/lib/bjlib/
mv ${pkgdir}/usr/lib/cups/backend ${pkgdir}/usr/lib32/cups/
install -d ${pkgdir}/usr/lib/cups/backend
ln -rs ${pkgdir}/usr/lib32/cups/backend/* ${pkgdir}/usr/lib/cups/backend/