summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2016-05-09 16:28:27 +0430
committerMax Qian2016-06-01 23:07:35 -0700
commit7ef89be818c4742be6483023a8cdd690d9decc8a (patch)
treeeb4456848008aa331ea59b1601be46fa9bc726c9 /PKGBUILD
parentba78e7fb8dd2cc7559b7ba67d33d6073b0a290d0 (diff)
downloadaur-7ef89be818c4742be6483023a8cdd690d9decc8a.tar.gz
symlinking bjlib files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f84c95063660..51d44dd366be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=('cnijfilter-mx920')
_pkgname=cnijfilter
pkgver=3.90
-pkgrel=1
+pkgrel=2
_pkgreview=1
pkgdesc="Canon IJ printer driver (multifunction MX920 series)"
@@ -15,11 +15,11 @@ url="http://www.canon-europe.com/support/consumer_Products/products/fax__multifu
arch=('i686' 'x86_64')
license=('custom')
-makedepends_x86_64=('gcc-multilib' 'lib32-popt')
-depends_x86_64=('lib32-gtk2' 'lib32-libxml2')
+makedepends_x86_64=('gcc-multilib')
+depends_x86_64=('lib32-gtk2')
-makedepends_i686=('gcc' 'popt')
-depends_i686=('gtk2' 'libxml2')
+makedepends_i686=('gcc')
+depends_i686=('gtk2')
makedepends=('autoconf>=2.13' 'automake>=1.6' 'tar' 'make')
depends=("${_pkgname}-common=4.00")
@@ -50,6 +50,8 @@ build() {
# TODO: it looks like the libaries can also be built for 64 bit natively
export CC="gcc -m32"
+ # Required for the glib2
+ export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
make mx920
}
@@ -58,7 +60,9 @@ package() {
make PACKAGEDIR=${pkgdir} installmx920
install -d ${pkgdir}/usr/lib32/bjlib
+ install -d ${pkgdir}/usr/lib/bjlib
install -m 644 417/database/* ${pkgdir}/usr/lib32/bjlib/
+ ln -rs ${pkgdir}/usr/lib32/bjlib/* ${pkgdir}/usr/lib/bjlib/
install -s -m 755 417/libs_bin32/*.so.* ${pkgdir}/usr/lib32/
install -D LICENSE-cnijfilter-${pkgver}EN.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-cnijfilter-${pkgver}EN.txt