summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBehnam Momeni2015-06-24 20:13:21 +0430
committerBehnam Momeni2015-06-24 20:13:21 +0430
commit9f2dd14e16c5bc0a84c76c0e1e6be2cdf774ea26 (patch)
treed652230bf5172aaffe78d80f5abd82f693007703 /PKGBUILD
parentd38c265e0b5411d6db00502d621c0caaf8fbe969 (diff)
downloadaur-9f2dd14e16c5bc0a84c76c0e1e6be2cdf774ea26.tar.gz
Converting from split-package to normal package
As multiple cnijfilter packages are dependent on the cnijfilter-common package and "split package" mechanism does not allow to build all of them (with different configurations) using a single PKGBUILD, either all of them must merge cnijfilter-common contents into their packages, which is the worst solution, or only build their own normal packages and depend on cnijfilter-common package, which is created from a separate PKGBUILD itself.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 7 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd27ce8c6962..e8844dfcaec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,29 @@
# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
# Contributor: Stefan Hackl <stef.hackl [at the] gmail [dot] com>
-pkgbase=('cnijfilter-mp550')
-
pkgname=('cnijfilter-mp550')
-true && pkgname=('cnijfilter-common' 'cnijfilter-mp550')
_pkgname=cnijfilter
pkgver=3.20
-pkgrel=8
+pkgrel=9
_pkgreview=1
-pkgdesc="Canon Printer Driver (For Multifunction MP550 series)"
+pkgdesc="Canon IJ Printer Driver (For Multifunction MP550 series)"
url="http://www.canon-europe.com/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MP_series/PIXMA_MP550.aspx"
arch=('i686' 'x86_64')
license=('custom')
-conflicts=('lib32-cnijfilter320')
if [ "${CARCH}" = 'x86_64' ]; then
makedepends=('gcc-multilib' 'lib32-popt')
+ depends=('lib32-gtk2' 'lib32-libxml2' "${_pkgname}-common=${pkgver}")
elif [ "${CARCH}" = 'i686' ]; then
makedepends=('gcc' 'popt')
+ depends=('gtk2' 'libxml2' "${_pkgname}-common=${pkgver}")
fi
makedepends+=('autoconf>=2.13' 'automake>=1.6' 'tar' 'make')
+install=cnijfilter-mp550.install
# File size: 6552576 bytes
source=("http://files.canon-europe.com/files/soft37280/Software/IJ_Linux_Printer_Driver_Source_320.tar"
@@ -36,7 +35,7 @@ sha512sums=('28a82d08d3b8a233b89a17e0e029510fc5b3cede97300eb71a9af03c9a15cca4355
'b75cdbdadac5fb396458dc9f14529c5e39a4fa47f97cd6a21a69b0dbac73f1b8dd90780068f6a348fcfb15939d0866dde1a1cf1ff7faaf0c443d2205a242ccd5'
'f1f8cc44d7892eb50b44e0fe9d5be877fa5d8f8783aedf494d739eee20c147befac4f4776959f42cdb9cfd9f766522635fc2aae2626fdaf0c4465226a66dcc0e'
'0d8310867f45721150a870170172d3a0688bfba0267f627a630c105ff965d31f25dbcc31d3795874325bcb8eaeee395bf32b0648a743ff663dea6f977ab9070e'
- '0e9dd821289f34da20e7d978583edeccde2cbfca8f0f78273bd2f4de63f7eab4e017d5c60395bc229fceea85c64c916e04be9b227b9af018b9d387e26a5a2b99')
+ '05eaef447a3145fe735ae856d86375144b368c378e86bf642db084a1f16eb474e0c1cf8df592620db76b6b99ff6dcd16b15c6c74f5ee9e00a3703c0bf104bf66')
prepare() {
cd ${srcdir}
@@ -57,51 +56,7 @@ build() {
make mp550
}
-package_cnijfilter-common() {
- pkgdesc="Canon IJ Printer Driver - Common files (32-bit)"
- install=cnijfilter-common.install
-
- if [ "${CARCH}" = 'x86_64' ]; then
- depends=('lib32-libcups' 'lib32-popt')
- elif [ "${CARCH}" = 'i686' ]; then
- depends=('libcups' 'popt')
- fi
-
- cd ${srcdir}/${_pkgname}-source-${pkgver}-${_pkgreview}
-
- make PACKAGEDIR=${pkgdir} installcommon
-
- install -d ${pkgdir}/usr/lib32/bjlib
- if [ "${CARCH}" = 'x86_64' ]; then
- install -d ${pkgdir}/usr/lib
- ln -s /usr/lib32/bjlib ${pkgdir}/usr/lib/bjlib
- fi
-
- install -m 644 com/ini/cnnet.ini ${pkgdir}/usr/lib32/bjlib
- install -s -m 755 com/libs_bin/libcnnet.so.1.1.0 ${pkgdir}/usr/lib32
-
- install -D LICENSE-cnijfilter-${pkgver}EN.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-cnijfilter-${pkgver}EN.txt
-
- if [ "${CARCH}" = 'x86_64' ]; then
- mv ${pkgdir}/usr/lib/cups/backend ${pkgdir}/usr/lib32/cups/
- install -d ${pkgdir}/usr/lib/cups/backend
- ln -s /usr/lib32/cups/backend/cnijnet ${pkgdir}/usr/lib/cups/backend/
- ln -s /usr/lib32/cups/backend/cnijusb ${pkgdir}/usr/lib/cups/backend/
- install -d ${pkgdir}/usr/lib/cups/filter
- ln -s /usr/lib32/cups/filter/pstocanonij ${pkgdir}/usr/lib/cups/filter/
- fi
-}
-
-package_cnijfilter-mp550() {
- pkgdesc="Canon IJ Printer Driver (For Multifunction MP550 series)"
- install=cnijfilter-mp550.install
-
- if [ "${CARCH}" = 'x86_64' ]; then
- depends=('lib32-gtk2' 'lib32-libxml2' "${_pkgname}-common=${pkgver}")
- elif [ "${CARCH}" = 'i686' ]; then
- depends=('gtk2' 'libxml2' "${_pkgname}-common=${pkgver}")
- fi
-
+package() {
cd ${srcdir}/cnijfilter-source-${pkgver}-${_pkgreview}
make PACKAGEDIR=${pkgdir} installmp550